Skip to content

Commit

Permalink
media-sound/alsa-utils: Bump to version 1.1.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Mar 31, 2016
1 parent 7ec65f8 commit 62072e5
Show file tree
Hide file tree
Showing 3 changed files with 77 additions and 2 deletions.
1 change: 1 addition & 0 deletions media-sound/alsa-utils/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST alsa-utils-1.0.27.2.tar.bz2 1143802 SHA256 02bfac39092f3b68d743c23ad3d688d6
DIST alsa-utils-1.0.28.tar.bz2 1146887 SHA256 f3ff4c89b0125a7797b1b13cd094cc92276e655458274967386e812d03642acc SHA512 faa5abf3f066106c80d019944efa2298e2d3157469c1c7bc52deb9aa1bcd5f5439a2e22b04ad9210e292fcef97bdacc27aa75fc275d0d7cae2c2f88729c84786 WHIRLPOOL d58587d9f302f3f1a7ab4de45c3889ce82e5be782e4aa9a953c39a908a4693e99c8ea9aeeb5669f0f606d980983beb7d5fc53e4c76ce1bb76500c7c2bcb45013
DIST alsa-utils-1.0.29.tar.bz2 1154497 SHA256 5160058f3e14483ced5de919dd473f93932059454530a9b7ef97dcabd6833e9b SHA512 0d83805aa7b1c975524cc5ecd4aa6eb36126bc434458f9e9475e4bd1b14bbb4bf9691096ca7973342a3798e97a361451c078f4595f8f4275db64d6b443ca5928 WHIRLPOOL ccad5115148045e0c5f139d70306e801e250aa3946f60d9cd0a47c84c72f6d8689e53105030589309c98ddd4a7b871bb8dc03f00fcc3d46cc3e08c4718299407
DIST alsa-utils-1.1.0.tar.bz2 1181085 SHA256 3b1c3135b76e14532d3dd23fb15759ddd7daf9ffbc183f7a9a0a3a86374748f1 SHA512 c61f056959feba015bb4a6f49980c4beb6a0c34be09e7196864583897ea86373b593a8807999a07df9c87a3a0c714075b9aae516752e83a946d0d60bc8f90f98 WHIRLPOOL 50d8e1506fb9f969b3dfcd618933efbeda6f938c3350eccf99526fb8329afd1ea4381ff1a548590f0f9bae12bdb63c1e8ab068641743d52b3ba609eae2d337e5
DIST alsa-utils-1.1.1.tar.bz2 1186408 SHA256 89757c9abaf420831b088fce354d492acc170bd02bb50eb7392c175f594b8041 SHA512 3af1e43cb2eab7e5119d83036ab6f4eeb106b66b4a57122cc8df243b6dbda90d39a0290a2af3a904b4929e2d90e8fcded9eda2a38bae1fd8e371a6d7a043376e WHIRLPOOL ea7daaf4055469dd5cb128abbe9a986e2b99b27c59d964041a92e82667e520adadb1e87d38bfa83d5b8ffbc382d7d9401c9d4887ca19546e4d1f34ba1cf7d705
74 changes: 74 additions & 0 deletions media-sound/alsa-utils/alsa-utils-1.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils systemd udev

DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
HOMEPAGE="http://www.alsa-project.org/"
SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0.9"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
IUSE="bat doc +libsamplerate +ncurses nls selinux"

CDEPEND=">=media-libs/alsa-lib-${PV}
libsamplerate? ( media-libs/libsamplerate )
ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
bat? ( sci-libs/fftw:= )"
DEPEND="${CDEPEND}
virtual/pkgconfig
doc? ( app-text/xmlto )"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-alsa )"

src_configure() {
local myconf
use doc || myconf='--disable-xmlto'

# --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
econf \
--disable-maintainer-mode \
$(use_enable bat) \
$(use_enable libsamplerate alsaloop) \
$(use_enable nls) \
$(use_enable ncurses alsamixer) \
--disable-alsaconf \
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
--with-udev-rules-dir="$(get_udevdir)"/rules.d \
${myconf}
}

src_install() {
default
dodoc seq/*/README.*

newinitd "${FILESDIR}"/alsasound.initd-r6 alsasound
newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound

insinto /etc/modprobe.d
newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf

keepdir /var/lib/alsa

# ALSA lib parser.c:1266:(uc_mgr_scan_master_configs) error: could not
# scan directory /usr/share/alsa/ucm: No such file or directory
# alsaucm: unable to obtain card list: No such file or directory
keepdir /usr/share/alsa/ucm
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog
elog "To take advantage of the init script, and automate the process of"
elog "saving and restoring sound-card mixer levels you should"
elog "add alsasound to the boot runlevel. You can do this as"
elog "root like so:"
elog "# rc-update add alsasound boot"
ewarn
ewarn "The ALSA core should be built into the kernel or loaded through other"
ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
fi
}
4 changes: 2 additions & 2 deletions media-sound/alsa-utils/files/alsasound.initd-r6
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
#!/sbin/runscript
#!/sbin/openrc-run
# $Id$
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

alsastatedir=/var/lib/alsa
Expand Down

0 comments on commit 62072e5

Please sign in to comment.