forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-emulation/snes9x: Fix broken build system
Closes: https://bugs.gentoo.org/645330 Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
1 parent
dcdaf4f
commit 622178a
Showing
2 changed files
with
67 additions
and
1 deletion.
There are no files selected for viewing
63 changes: 63 additions & 0 deletions
63
games-emulation/snes9x/files/snes9x-1.55-build-system.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,63 @@ | ||
--- a/gtk/configure.ac | ||
+++ b/gtk/configure.ac | ||
@@ -33,7 +33,7 @@ | ||
|
||
AM_GLIB_GNU_GETTEXT | ||
|
||
-snes9xlocaledir='${prefix}/${DATADIRNAME}/locale' | ||
+snes9xlocaledir='$(localedir)' | ||
AC_SUBST(snes9xlocaledir) | ||
|
||
AC_ARG_WITH(debug, | ||
--- a/unix/configure.ac | ||
+++ b/unix/configure.ac | ||
@@ -56,49 +56,6 @@ | ||
# *** Execution begins here *** | ||
# ***************************** | ||
|
||
-# Remove -g and -O2 flags manually. | ||
- | ||
-if test "x$CFLAGS" != "x"; then | ||
- CFLAGS="`echo \"$CFLAGS\" | sed -e 's/-g//'`" | ||
- CFLAGS="`echo \"$CFLAGS\" | sed -e 's/-O2//'`" | ||
-fi | ||
- | ||
-if test "x$CXXFLAGS" != "x"; then | ||
- CXXFLAGS="`echo \"$CXXFLAGS\" | sed -e 's/-g//'`" | ||
- CXXFLAGS="`echo \"$CXXFLAGS\" | sed -e 's/-O2//'`" | ||
-fi | ||
- | ||
-# Test what compiler flags we should use. | ||
- | ||
-AC_ARG_ENABLE([debug], | ||
- [AS_HELP_STRING([--enable-debug], | ||
- [leave debug information in the final binary (default: no)])], | ||
- [], [enable_debug="no"]) | ||
- | ||
-if test "x$enable_debug" = "xyes"; then | ||
- AC_S9X_COMPILER_FLAG([-g], [g]) | ||
- AC_S9X_COMPILER_FLAG([-O0], [o0]) | ||
-else | ||
- AC_S9X_COMPILER_FLAG([-O3], [o3], [ | ||
- AC_S9X_COMPILER_FLAG([-O2], [o2], [ | ||
- AC_S9X_COMPILER_FLAG([-O1], [o1])])]) | ||
- AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer]) | ||
-fi | ||
- | ||
-AC_ARG_ENABLE([mtune], | ||
- [AS_HELP_STRING([--enable-mtune], | ||
- [use the specified value for the -mtune/-mcpu flag (default: no)])], | ||
- [], [enable_mtune="no"]) | ||
- | ||
-if test "x$enable_mtune" != "xno"; then | ||
- AC_S9X_COMPILER_FLAG([-mtune="$enable_mtune"], [mtune], | ||
- [ | ||
- AC_MSG_WARN([-mtune failed, trying -mcpu...]) | ||
- AC_S9X_COMPILER_FLAG([-mcpu="$enable_mtune"], [mcpu], | ||
- [AC_MSG_ERROR([Please specify a working value for --enable-mtune.])]) | ||
- ]) | ||
-fi | ||
- | ||
AC_S9X_COMPILER_FLAG([-fno-exceptions], [no_exceptions]) | ||
AC_S9X_COMPILER_FLAG([-fno-rtti], [no_rtti]) | ||
AC_S9X_COMPILER_FLAG([-pedantic], [pedantic]) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters