Skip to content

Commit

Permalink
dev-util/cgdb: add 0.8.0
Browse files Browse the repository at this point in the history
With tests restricted as they are broken now.

Closes: https://bugs.gentoo.org/831899
Signed-off-by: Jakov Smolić <[email protected]>
  • Loading branch information
jsmolic committed Jan 24, 2022
1 parent e3d5ab0 commit 6223b41
Show file tree
Hide file tree
Showing 3 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/cgdb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cgdb-0.7.1.tar.gz 314768 BLAKE2B 767a57d071fa4e3c75d231a1ec879d871669fcda9c733d157d380fa525dd321f1deb68d7ef7f424b3f36a115043a0a0faae271f24746f934e288ba7d9a4e7fa1 SHA512 050c7bad963d51c1a2cb309530319ca77e9d236f419fb0abac4ab5030ff1068d799fa626959a8b3036321711de98bddf40d264bf9367ff5697075e30ca8168c6
DIST cgdb-0.8.0.tar.gz 328281 BLAKE2B 60e577dd5f8363b91da33136a9ffd911581e9cea4cdc1d0fcd338e0a761a26921e6edf6298c619b8d0eb1486449843457b2c5370a395a8c49fed5382a60e63a2 SHA512 e2b653db472de2014402dae6d13953ab811526a47ad5d7a05e34cfba09f44d6fea6b19304b9205ff0e2ac9549ffa5818f4282d7c03293b6c0ca9d563f9ae89e1
69 changes: 69 additions & 0 deletions dev-util/cgdb/cgdb-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/cgdb/cgdb.git"
else
SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
fi

inherit autotools multilib-minimal

DESCRIPTION="A curses front-end for GDB, the GNU debugger"
HOMEPAGE="https://cgdb.github.io/"

LICENSE="GPL-2"
SLOT="0"
IUSE="test"
# Tests are broken, need additional research to figure out the cause
# Bug: https://bugs.gentoo.org/831899
RESTRICT="test"

DEPEND="
sys-libs/ncurses:0=
sys-libs/readline:0="

BDEPEND="
test? (
dev-util/dejagnu
app-misc/dtach
)"

RDEPEND="
${DEPEND}
sys-devel/gdb"

DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )

PATCHES=(
"${FILESDIR}"/${P}-ar.patch
)

src_prepare() {
default
AT_M4DIR="config" eautoreconf
}

multilib_src_test() {
# Tests need an interactive shell, #654986

# real-time output of the log ;-)
touch "${T}/dtach-test.log" || die
tail -f "${T}/dtach-test.log" &
local tail_pid=${!}

nonfatal dtach -N "${T}/dtach.sock" \
bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'

kill "${tail_pid}"
[[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
[[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf
}
18 changes: 18 additions & 0 deletions dev-util/cgdb/files/cgdb-0.8.0-ar.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
Bug: https://bugs.gentoo.org/724256
Patch taken from https://github.com/cgdb/cgdb/pull/142
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,13 @@ AC_PROG_INSTALL
AC_PROG_RANLIB
AM_PROG_LEX
AC_PROG_YACC
+m4_ifndef([AC_PROG_AR],[dnl
+ AN_MAKEVAR([AR], [AC_PROG_AR])
+ AN_PROGRAM([ar], [AC_PROG_AR])
+ AC_DEFUN([AC_PROG_AR],
+ [AC_CHECK_TOOL(AR, ar, :)])
+])
+AC_PROG_AR

dnl determine if we are running in linux, cygwin, solaris, or freebsd
AC_CANONICAL_HOST

0 comments on commit 6223b41

Please sign in to comment.