Skip to content

Commit

Permalink
app-i18n/opencc: Update patch for parallel build failure.
Browse files Browse the repository at this point in the history
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <[email protected]>
Signed-off-by: Mike Gilbert <[email protected]>
  • Loading branch information
Arfrever Frehtes Taifersar Arahesis authored and floppym committed Dec 27, 2020
1 parent a41dde6 commit 6249125
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 1 deletion.
40 changes: 40 additions & 0 deletions app-i18n/opencc/files/opencc-1.1.0-parallel_build.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
https://github.com/BYVoid/OpenCC/issues/322

--- /data/CMakeLists.txt
+++ /data/CMakeLists.txt
@@ -116,6 +116,19 @@
)
endforeach(DICT)

+add_custom_target(
+ copy_libopencc_to_dir_of_opencc_dict
+ COMMENT
+ "Copying libopencc to directory of opencc_dict"
+ COMMAND
+ ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
+)
+if (WIN32)
+ set(DICT_WIN32_DEPENDS copy_libopencc_to_dir_of_opencc_dict)
+else()
+ set(DICT_WIN32_DEPENDS)
+endif()
+
foreach(DICT ${DICTS})
add_custom_command(
OUTPUT
@@ -123,14 +136,13 @@
COMMENT
"Building ${DICT}.ocd2"
COMMAND
- ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
- COMMAND
${OPENCC_DICT_BIN}
--input ${DICT_${DICT}_INPUT}
--output ${DICT}.ocd2
--from text
--to ocd2
DEPENDS
+ ${DICT_WIN32_DEPENDS}
${OPENCC_DICT_BIN}
${DICT_${DICT}_INPUT}
)
2 changes: 1 addition & 1 deletion app-i18n/opencc/opencc-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -42,7 +42,7 @@ if [[ "${PV}" != "9999" ]]; then
fi

PATCHES=(
"${FILESDIR}/${PN}-stop-copy.patch"
"${FILESDIR}/${PN}-1.1.0-parallel_build.patch"
)

DOCS=(AUTHORS NEWS.md README.md)
Expand Down

0 comments on commit 6249125

Please sign in to comment.