forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/clucene: Fix build with gcc-6
Revision bump adds pending upstream patch which fixes build with gcc-6. Gentoo-bug: 582868 Thanks-to: Peter Levine <[email protected]> Package-Manager: portage-2.3.0_rc1
- Loading branch information
Showing
2 changed files
with
89 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
MY_PN="${PN}"-core | ||
MY_P="${MY_PN}"-"${PV}" | ||
|
||
inherit cmake-utils multilib | ||
|
||
DESCRIPTION="High-performance, full-featured text search engine based off of lucene in C++" | ||
HOMEPAGE="http://clucene.sourceforge.net/" | ||
SRC_URI="mirror://sourceforge/clucene/${MY_P}.tar.gz" | ||
|
||
LICENSE="|| ( Apache-2.0 LGPL-2.1 )" | ||
SLOT="1" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos" | ||
|
||
IUSE="debug doc static-libs" | ||
|
||
DEPEND=" | ||
doc? ( >=app-doc/doxygen-1.4.2 ) | ||
" | ||
RDEPEND="!<app-misc/strigi-0.7.5-r3" | ||
|
||
RESTRICT="test" | ||
|
||
DOCS=(AUTHORS ChangeLog README README.PACKAGE REQUESTS) | ||
|
||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-contrib.patch" | ||
"${FILESDIR}/${P}-pkgconfig.patch" | ||
"${FILESDIR}/${P}-gcc6.patch" | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# patch out installing bundled boost headers, we build against system one | ||
sed -i \ | ||
-e '/ADD_SUBDIRECTORY (src\/ext)/d' \ | ||
CMakeLists.txt || die | ||
rm -rf src/ext || die | ||
} | ||
|
||
src_configure() { | ||
# Disabled threads: see upstream bug | ||
# https://sourceforge.net/tracker/?func=detail&aid=3237301&group_id=80013&atid=558446 | ||
local mycmakeargs=( | ||
-DENABLE_ASCII_MODE=OFF | ||
-DENABLE_PACKAGING=OFF | ||
-DDISABLE_MULTITHREADING=OFF | ||
-DBUILD_CONTRIBS_LIB=ON | ||
"-DLIB_DESTINATION=${EPREFIX}/usr/$(get_libdir)" | ||
-DENABLE_DEBUG=$(usex debug) | ||
-DENABLE_CLDOCS=$(usex doc) | ||
-DBUILD_STATIC_LIBRARIES=$(usex static-libs) | ||
) | ||
|
||
cmake-utils_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
From b5a1b3488a72abd250cbd5d4dfbeac3e3739c237 Mon Sep 17 00:00:00 2001 | ||
From: Hodorgasm <[email protected]> | ||
Date: Thu, 12 May 2016 20:38:12 -0400 | ||
Subject: [PATCH] Support GCC-6 | ||
|
||
--- | ||
src/shared/cmake/MacroCheckGccVisibility.cmake | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/src/shared/cmake/MacroCheckGccVisibility.cmake b/src/shared/cmake/MacroCheckGccVisibility.cmake | ||
index 2022aa3..020f913 100644 | ||
--- a/src/shared/cmake/MacroCheckGccVisibility.cmake | ||
+++ b/src/shared/cmake/MacroCheckGccVisibility.cmake | ||
@@ -15,7 +15,7 @@ macro(MACRO_CHECK_GCC_VISIBILITY GccVisibility) | ||
# get the gcc version | ||
exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info) | ||
|
||
- string (REGEX MATCH "[345]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}") | ||
+ string (REGEX MATCH "[3456]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}") | ||
if (NOT _gcc_version) | ||
|
||
# clang reports: clang version 1.1 (trunk 95754) | ||
-- | ||
2.8.2 | ||
|