Skip to content

Commit

Permalink
www-apps/grafana-bin: bump to v7.5.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Apr 14, 2021
1 parent 52e9156 commit 62b2847
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-apps/grafana-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST grafana-bin-7.4.5.tar.gz 51268864 BLAKE2B c59e16dd8cde882c8f7ffaa3352aeaf38f2fa1e5da3d340796403b0719d33b9eeb5fb7d8ac54b8321f2617d534a3121d2f8a86462e7cf07019baf2a08b141cc2 SHA512 8ad7e2fa9ca92a406690f5a14ea111ff329e6abb4330d4ede5bb34870c3d28cdec940db4c849bb99c097276ad10a3d4c70cf6b73ed8286d45fdf056673d0892f
DIST grafana-bin-7.5.1.tar.gz 55420645 BLAKE2B 1100f68eeaeda5dd4d7928c0e16bcefe686427866472a750228eaa5612bc7c7d40db24d8767ae8e9766d70593de2504c57cb8a145efa1ff81074d38c69452ca7 SHA512 bee8b95820a8d8983aa430ee1e7de65da0b90ecfe0eeab8d8a5486af818a4bede73846bcc5aae2c9735204be004171ae98bccd7546d3c0220030260f1f1ed203
DIST grafana-bin-7.5.2.tar.gz 52181388 BLAKE2B 7203ffb42169d9b92b2f251015195373abe58619ec7da7e65037d30a7a856e02dd07abc93c41b4f911fa1bd8b382d29e753f75b6717e65f211687127f0ce7ad9 SHA512 4eeff81371149f22f0c708d467623ace32ef1c9cd812d232c21323eeeb9bfa4e54658bca875b6c40c9b25caa4a56ea43e39b5389753348cc79710228ae135309
DIST grafana-bin-7.5.4.tar.gz 52194914 BLAKE2B d2a6666d0d45116fe8b3241d38bef837e306c621fd9eb1b4e3b99ece17465e93643a9a0ba98504255b32826a97d91559bc04ba2eed9bfa9398d7346e8147439e SHA512 690038d39269341f435b79d430e11d8e1a54367ae2ccf3b5f625b8e7b87bbce2f9c650e1b446522a475c7c3b7da91786e93d5964150c9c208471febc1e498300
64 changes: 64 additions & 0 deletions www-apps/grafana-bin/grafana-bin-7.5.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit systemd

MY_PN=${PN/-bin/}
MY_PV=${PV/_beta/-beta}
S=${WORKDIR}/${MY_PN}-${MY_PV}

DESCRIPTION="Gorgeous metric viz, dashboards & editors for Graphite, InfluxDB & OpenTSDB"
HOMEPAGE="https://grafana.org"
SRC_URI="https://dl.grafana.com/oss/release/grafana-${PV}.linux-amd64.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="acct-group/grafana
acct-user/grafana"
RDEPEND="${DEPEND}
media-libs/fontconfig"

QA_PREBUILT="usr/bin/grafana-*"
QA_PRESTRIPPED=${QA_PREBUILT}

src_install() {
keepdir /etc/grafana
insinto /etc/grafana
newins "${S}"/conf/sample.ini grafana.ini
rm "${S}"/conf/sample.ini || die

# Frontend assets
insinto /usr/share/${MY_PN}
doins -r public conf

dobin bin/grafana-cli
dobin bin/grafana-server

newconfd "${FILESDIR}"/grafana-r1.confd grafana
newinitd "${FILESDIR}"/grafana.initd grafana
systemd_newunit "${FILESDIR}"/grafana.service grafana.service

keepdir /var/{lib,log}/grafana
keepdir /var/lib/grafana/{dashboards,plugins}
fowners grafana:grafana /var/{lib,log}/grafana
fowners grafana:grafana /var/lib/grafana/{dashboards,plugins}
fperms 0750 /var/{lib,log}/grafana
fperms 0750 /var/lib/grafana/{dashboards,plugins}
}

postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
# This is a new installation

elog "${PN} has built-in log rotation. Please see [log.file] section of"
elog "/etc/grafana/grafana.ini for related settings."
elog
elog "You may add your own custom configuration for app-admin/logrotate if you"
elog "wish to use external rotation of logs. In this case, you also need to make"
elog "sure the built-in rotation is turned off."
fi
}

0 comments on commit 62b2847

Please sign in to comment.