Skip to content

Commit

Permalink
mail-client/neomutt: Version bump to neomutt-20171215
Browse files Browse the repository at this point in the history
Starting with this release, upstream deprecated the `autotools` build
system and replaced it with one based on `autosetup`. This change
introduces a build dependency (dev-lang/tcl) and changes a few arguments
from `--with` to `--enable`.

Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
nicolasbock committed Dec 15, 2017
1 parent 99c7235 commit 62cee3a
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/neomutt/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST neomutt-20171006.tar.gz 2706019 BLAKE2B b16f065fd1c5b829c6b73614c42e5353b96
DIST neomutt-20171013.tar.gz 2706753 BLAKE2B d8801f4168ce978b8b2578a1fa28b8f29e98700c2b3c11dcce7b9cdf132a755403ed1b54216426736c1dde78c580320ebac4fbb6e3ca6f92abc1c1e6d1e4fd1b SHA512 9e4499b165f25091d73868c62b14f950bdfc032444c0cb3619e99a8299d29c3d1f24078e15537e693a3af69ae0681d59e25a73b857882cce2653be593231ffac
DIST neomutt-20171027.tar.gz 2682699 BLAKE2B 4e3eda453a8c19d2ec1460c0813e030ef8209e8761d1ef768698cf624c11a2d3b22b941da78fb2d39ef44d6f39c7b30786248448910e59170f50b6d6e010a331 SHA512 e2df0d20c0729abb32d1614c94c08cca0cecad1cb36a380f8210e2df3e353ffc08f66abf1e5e3a1cf4a746437d59c15262ce05ab1a820561466bf7e3a5d6b894
DIST neomutt-20171208.tar.gz 2703917 BLAKE2B 709cdb7b00e887f01bf6b1e805b25938ceca1a25d77c8674150e32ae4ac28aad10479ab54f172e2b07cab98b903973190faa138de1061ebbf4fcbe09d544ecf9 SHA512 e4f8a5f01d96d6f82959fe583634585deee28cf146c768e5049281b273c5b76b91ee01c9d9382a26f72a092c14341905129e73bf5c6ba19baae7823bc6680671
DIST neomutt-20171215.tar.gz 2680191 BLAKE2B 9826537ed985cf56e4a52e0938967645ca607fcd57f455e1a521a67875bacc397e1706099291fe5a7a350542d0bc07b7835a908c64d84067fb12e39f973af545 SHA512 8098f537e8ef7d3f7aa87fc875c0dc079b996285b786fe6fc6bdf18154c1282b03a4e19dd6902a110616443ca2b23008c8c1f5c4a615c53b620b537c50dfb658
134 changes: 134 additions & 0 deletions mail-client/neomutt/neomutt-20171215.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils flag-o-matic

if [[ ${PV} =~ 9999$ ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/neomutt-${P}"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="A small but very powerful text-based mail client"
HOMEPAGE="https://www.neomutt.org/"

LICENSE="GPL-2"
SLOT="0"
IUSE="berkdb crypt doc gdbm gnutls gpg gpgme idn kerberos kyotocabinet
libressl lmdb nls notmuch pgp_classic qdbm sasl selinux slang smime
smime_classic ssl tokyocabinet"

CDEPEND="
app-misc/mime-types
berkdb? ( >=sys-libs/db-4:= )
gdbm? ( sys-libs/gdbm )
kyotocabinet? ( dev-db/kyotocabinet )
lmdb? ( dev-db/lmdb )
nls? ( virtual/libintl )
qdbm? ( dev-db/qdbm )
tokyocabinet? ( dev-db/tokyocabinet )
gnutls? ( >=net-libs/gnutls-1.0.17 )
gpg? ( >=app-crypt/gpgme-0.9.0 )
gpgme? ( >=app-crypt/gpgme-0.9.0 )
idn? ( net-dns/libidn )
kerberos? ( virtual/krb5 )
notmuch? ( net-mail/notmuch )
sasl? ( >=dev-libs/cyrus-sasl-2 )
!slang? ( sys-libs/ncurses:0 )
slang? ( sys-libs/slang )
ssl? (
!libressl? ( >=dev-libs/openssl-0.9.6:0 )
libressl? ( dev-libs/libressl )
)
"
DEPEND="${CDEPEND}
dev-lang/tcl
net-mail/mailbase
doc? (
dev-libs/libxml2
dev-libs/libxslt
app-text/docbook-xsl-stylesheets
|| ( www-client/lynx www-client/w3m www-client/elinks )
)"
RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-mutt )
"

S="${WORKDIR}/${PN}-${P}"

src_configure() {
local myconf=(
"$(use_enable doc)"
"$(use_enable nls)"
"$(use_enable notmuch)"

# During the transition of the crypto USE flags we need to support
# both sets of flags. We do not want to emit a configuration setting
# twice, since the second flag overrides the first, potentially
# leading to unwanted settings. See https://bugs.gentoo.org/640824 for
# details.
"$(if use gpg || use gpgme; then echo "--enable"; else echo "--disable"; fi)-gpgme"
"$(if use crypt || use pgp_classic; then echo "--enable"; else echo "--disable"; fi)-pgp"
"$(if use smime || use smime_classic; then echo "--enable"; else echo "--disable"; fi)-smime"

# Database backends.
"$(use_enable berkdb bdb)"
"$(use_enable gdbm)"
"$(use_enable kyotocabinet)"
"$(use_enable qdbm)"
"$(use_enable tokyocabinet)"

"$(use_enable idn)"
"$(use_enable kerberos gss)"
"$(use_enable lmdb)"
"$(use_enable sasl)"
"--with-ui=$(usex slang slang ncurses)"
"--sysconfdir=${EPREFIX}/etc/${PN}"
"$(use_enable ssl)"
"$(use_enable gnutls)"
)

econf "${myconf[@]}"
}

src_install() {
emake DESTDIR="${D}" install

# A man-page is always handy, so fake one
if use !doc; then
emake -C doc neomuttrc.man
# make the fake slightly better, bug #413405
sed -e 's#@docdir@/manual.txt#http://www.neomutt.org/guide#' \
-e 's#in @docdir@,#at http://www.neomutt.org/,#' \
-e "s#@sysconfdir@#${EPREFIX}/etc/${PN}#" \
-e "s#@bindir@#${EPREFIX}/usr/bin#" \
doc/neomutt.man > neomutt.1 || die
cp doc/neomuttrc.man neomuttrc.5 || die
doman neomutt.1 neomuttrc.5
fi

dodoc COPYRIGHT LICENSE* ChangeLog* README*
}

pkg_postinst() {
if use crypt || use gpg || use smime; then
ewarn "Pleae note that the crypto related USE flags of neomutt have changed."
ewarn "(https://bugs.gentoo.org/637176)"
ewarn "crypt -> pgp_classic"
ewarn "gpg -> gpgme"
ewarn "smime -> smime_classic"
ewarn "The old USE flags still work but their use is deprecated and will"
ewarn "be removed in a future release."
if use gpg && ( use crypt || use smime ); then
ewarn " Note that gpgme (old gpg) includes both pgp and smime"
ewarn " support. You can probably remove pgp_classic (old crypt)"
ewarn " and smime_classic (old smime) from your USE-flags and"
ewarn " only enable gpgme."
fi
fi
}

0 comments on commit 62cee3a

Please sign in to comment.