forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-php/PEAR-Console_Getargs: Revbump for EAPI and eclass changes and…
… upstream patch Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Brian Evans
committed
Jul 6, 2017
1 parent
b7245c2
commit 630f649
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
18 changes: 18 additions & 0 deletions
18
dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.3.5-r1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
inherit php-pear-r2 | ||
|
||
DESCRIPTION="A command-line arguments parser" | ||
|
||
LICENSE="PHP-3" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" | ||
IUSE="" | ||
|
||
src_prepare() { | ||
eapply "${FILESDIR}/new-reference-fix.patch" | ||
eapply_user | ||
} |
22 changes: 22 additions & 0 deletions
22
dev-php/PEAR-Console_Getargs/files/new-reference-fix.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
From c769f79831c43f1cad0b4f8831276da93d28f479 Mon Sep 17 00:00:00 2001 | ||
From: Daniel O'Connor <[email protected]> | ||
Date: Sun, 6 Nov 2011 13:25:04 +1030 | ||
Subject: [PATCH] &new vs new | ||
|
||
--- | ||
Console/Getargs.php | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/Console/Getargs.php b/Console/Getargs.php | ||
index 8ba21c6..c6826ea 100644 | ||
--- a/Console/Getargs.php | ||
+++ b/Console/Getargs.php | ||
@@ -224,7 +224,7 @@ class Console_Getargs | ||
function &factory($config = array(), $arguments = null) | ||
{ | ||
// Create the options object. | ||
- $obj = & new Console_Getargs_Options(); | ||
+ $obj = new Console_Getargs_Options(); | ||
|
||
// Try to set up the arguments. | ||
$err = $obj->init($config, $arguments); |