Skip to content

Commit

Permalink
x11-plugins/gkrellm-volume: Eclass update
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Jan 4, 2018
1 parent 8a88923 commit 635494d
Showing 1 changed file with 11 additions and 12 deletions.
23 changes: 11 additions & 12 deletions x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit gkrellm-plugin toolchain-funcs

DESCRIPTION="A mixer control plugin for gkrellm"
Expand All @@ -13,22 +14,20 @@ SLOT="2"
KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
IUSE="alsa"

DEPEND="alsa? ( media-libs/alsa-lib )"
RDEPEND="${DEPEND}
app-admin/gkrellm[X]
"

S="${WORKDIR}/${PN}"

PLUGIN_SO="volume.so"
RDEPEND="
app-admin/gkrellm:2[X]
alsa? ( media-libs/alsa-lib )"
DEPEND="${RDEPEND}"

S=${WORKDIR}/${PN}
PATCHES=(
"${FILESDIR}/${P}-reenable.patch"
"${FILESDIR}/${P}-makefile.patch"
)

PLUGIN_SO=( volume$(get_modname) )

src_compile() {
local myconf=""
use alsa && myconf="${myconf} enable_alsa=1"
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" "${myconf}"
use alsa && local myconf="enable_alsa=1"
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}
}

0 comments on commit 635494d

Please sign in to comment.