Skip to content

Commit

Permalink
dev-lang/mujs: bump to 1.0.4
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/605554
Bug: https://bugs.gentoo.org/646784
Signed-off-by: Virgil Dupras <[email protected]>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
  • Loading branch information
Virgil Dupras committed Oct 7, 2018
1 parent ce6843f commit 63926da
Show file tree
Hide file tree
Showing 3 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/mujs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mujs-0_p20161202.tar.gz 105413 BLAKE2B a65a343d6f60975c88001cdd8eae881559eaf8ba94cf26c8aa9a9a3837cd47ee798c784ed9e90380a76ef328e56d63d1dccd8a85a4a7496d31046d221cf8d7b9 SHA512 90dd1bce44740715a6f642bdb376be230c4a03c7970c2026479cf014a080b98b56a2131ca7ef8bf9c05b91285fe7dcc21dd4ca83879750351d57088408a62cbc
DIST mujs-1.0.1.tar.gz 116948 BLAKE2B 54d898eff95e65688a51d9df9175964609a55ad3243ffaa4da10f27a6262a207777dd500cb76aefc22aa52799fed577864d15dfec9ed4aea24f0a4f1ff8dfa0a SHA512 46cbc45735dbf173d7fa5839e3b511730e4d42933c2286d170767659649ea88c2a3dcc74fb986d1eedb1d4fec8fcaaba146805cc9d0ef7da98bb5a9ce0c80a96
DIST mujs-1.0.4.tar.xz 91520 BLAKE2B 6ffe62b19b140e2ae63ebe59a3b3bd352936ccba53dda3b0fcf575440dc790a0767c7de8c0a1441d26c11c65074520a80050cc0efa1113be0df51a802e719574 SHA512 a32498fee20ab6ddc8bbf79b4fdd82f3560d4e4b28bbe57c4e8f1df4a8a5367a689b6c9a391761abe47a8f15d2832fede4a508330eb181744b9563ae9954c102
23 changes: 23 additions & 0 deletions dev-lang/mujs/files/mujs-1.0.4-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
1. Add to user-defined CFLAGS instead of being overwritten by them
2. Don't strip binaries: it leads to QA warnings
diff --git a/Makefile b/Makefile
index 7284f51..7615158 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ endif

# Compiler flags for various configurations:

-CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter

ifeq "$(CC)" "clang"
CFLAGS += -Wunreachable-code
@@ -32,7 +32,6 @@ else ifeq "$(build)" "sanitize"
LDFLAGS += -fsanitize=address
else
CFLAGS += -Os
- LDFLAGS += -Wl,-s
endif

ifeq "$(HAVE_READLINE)" "yes"
42 changes: 42 additions & 0 deletions dev-lang/mujs/mujs-1.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit flag-o-matic multilib toolchain-funcs

DESCRIPTION="lightweight Javascript interpreter"
HOMEPAGE="http://mujs.com/"
SRC_URI="https://mujs.com/downloads/${P}.tar.xz"

LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="static-libs"

PATCHES=(
"${FILESDIR}"/${PN}-1.0.4-gentoo.patch
)

src_prepare() {
default
append-cflags -fPIC -Wl,-soname=lib${PN}.so.${PV}
tc-export CC
}

src_compile() {
emake VERSION=${PV} prefix=/usr shared
}

src_install() {
emake \
DESTDIR="${ED}" \
VERSION=${PV} \
prefix=/usr \
libdir="/usr/$(get_libdir)" \
install-shared \
$(usex static-libs install-static '')

mv -v "${D}"/usr/$(get_libdir)/lib${PN}.so{,.${PV}} || die
dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so || die
dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV:0:1} || die
}

0 comments on commit 63926da

Please sign in to comment.