Skip to content

Commit

Permalink
media-plugins/gst-plugins-libav: bump to 1.12.3
Browse files Browse the repository at this point in the history
Updates bundled ffmpeg to v3.3.4 (used only with USE=libav) and a memory leak fix

Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
leio committed Sep 18, 2017
1 parent aefb1ca commit 63a6d9a
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/gst-plugins-libav/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gst-libav-1.10.4.tar.xz 8535052 SHA256 6ca0feca75e3d48315e07f20ec37cf6260ed1e9dde58df355febd5016246268b SHA512 4037c4651c9f4c0e677f1f8136194c16319507dec3992270c1f98d461a69a55653d261ade45add833103872455e09c30695318181e81242ce78d1c2a2b95ca9c WHIRLPOOL 441ed31e9886a71bace9fadd9edcf8102db621cffa9185c087535e7fa4daedb14dd2cbf3a067868f821d36b58982b482c0c37d82907e079cbe0f3e48bb8a27f3
DIST gst-libav-1.10.5.tar.xz 8545300 SHA256 e4d2f315f478d47281fbfdfbd590a63d23704ca37911d7142d5992616f4b28d3 SHA512 a0636a3b32a5c20eba69a0002fc549facebb0211774e13dd526a3a1eb710f3342662179af6275d619d5075ad0f6dc7068b9950cfb0c60e3ad48249475b39216b WHIRLPOOL 3b3ed00516ab8c4599ec249619390f4c4d478299bb5e14c2bbf532ab67d57881cf0584d33c78a6c5839008179b7815add6bf95437c7f2c65408469f9c4167457
DIST gst-libav-1.12.2.tar.xz 8784544 SHA256 5bb735b9bb218b652ae4071ea6f6be8eaae55e9d3233aec2f36b882a27542db3 SHA512 970c6c3ab71d1431196f3e95ef046cb28ba82e40b206f96fe8b70de2bf9c7ff1cf35e004f7f7dd92dac0ad5e94ed07d45a52dd1a90bdbe105cdd65235f0b6247 WHIRLPOOL 45a5754d12952cb5d242eae0da7d655dfe8f7c1fa5d496163d1291d56a02010d2552df9ca05f23fd9b9e02734832494297f3ac25f5cfde96886c9350186383c6
DIST gst-libav-1.12.3.tar.xz 8791724 SHA256 015ef8cab6f7fb87c8fb42642486423eff3b6e6a6bccdcd6a189f436a3619650 SHA512 33b380b7094afe1db57103eeeca5ae13db98a5bee6785f884a7ec8abb93a94f702eb52f0515f4fa27a0f157ecb0757cf3576df335dc456254f9a82567f5ab7a8 WHIRLPOOL 0d8a1189fb75f1c324309175e64548fd93dc69a914d71425f4028ac7c54b95b69555276a20771e47e4266135080aa54c2056e999808ccc6b203ae33922e47c5f
74 changes: 74 additions & 0 deletions media-plugins/gst-plugins-libav/gst-plugins-libav-1.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils multilib-minimal

MY_PN="gst-libav"
DESCRIPTION="FFmpeg based gstreamer plugin"
HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="1.0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="libav +orc"

# XXX: bzip2/lzma are automagic
# Move back to ${PV} deps of gstreamer/gst-plugins-base later; 1.10.4 had it reduced for lone security stabilization
RDEPEND="
app-arch/bzip2
app-arch/xz-utils
>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
>=media-libs/gstreamer-1.12.0:1.0[${MULTILIB_USEDEP}]
>=media-libs/gst-plugins-base-1.12.0:1.0[${MULTILIB_USEDEP}]
!libav? ( >=media-video/ffmpeg-3.2.4:0=[${MULTILIB_USEDEP}] )
orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
"

S="${WORKDIR}/${MY_PN}-${PV}"

RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly

multilib_src_configure() {
GST_PLUGINS_BUILD=""
# Upstream dropped support for system libav and won't work
# for preserving its compat anymore, forcing us to rely on internal
# ffmpeg copy if we don't want to cause unresolvable blockers for
# libav setups.
# https://bugzilla.gnome.org/show_bug.cgi?id=758183
# Prefer system ffmpeg for -libav
local myconf

if use libav; then
ewarn "Using internal ffmpeg copy as upstream dropped"
ewarn "the support for compiling against system libav"
ewarn "http://bugzilla.gnome.org/show_bug.cgi?id=758183"
else
myconf="--with-system-libav"
fi

ECONF_SOURCE=${S} \
econf \
--disable-maintainer-mode \
--with-package-name="Gentoo GStreamer ebuild" \
--with-package-origin="https://www.gentoo.org" \
--disable-fatal-warnings \
$(use_enable orc) \
${myconf}
}

multilib_src_compile() {
# Don't build with -Werror
emake ERROR_CFLAGS=
}

multilib_src_install_all() {
einstalldocs
prune_libtool_files --modules
}

0 comments on commit 63a6d9a

Please sign in to comment.