Skip to content

Commit

Permalink
app-metrics/mongodb_exporter: 0.6.2 bump
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
william-hubbs authored and williamh committed Mar 15, 2019
1 parent 564d56c commit 63c350c
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-metrics/mongodb_exporter/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST mongodb_exporter-0.4.0.tar.gz 3386266 BLAKE2B a6bebada2792e620b2107b72b3ab8b2a4e7a08fc53747f266b30a3cf2fe42ed7e09e3be9aa36332cba2df124947064f545821f355726e09649509c671a56c30b SHA512 0db1abd8c7439239cf59b24968ef33f83c6609a9deaed250315dd7fcb6844ef3d0d0c1f50b979f931beb539038a13eb7b88c03c899333d981112695be2e031b3
DIST mongodb_exporter-0.6.0.tar.gz 1274979 BLAKE2B 9e039d33048a7cc8552d39e9dbc6b04d26f062ac7c232088806318a69b2601b9ae98f09a41d255e9b6ac6883acfcda9511219513382837a0d88903cf31578bde SHA512 c9d7f46a6d7222e4dca105be9c306a6d558dacf185a726345988e262386c27ed63ef7022e524086f522aa0b5c7ff0ad6207863e83670c6116bb2b1e681abfc9d
DIST mongodb_exporter-0.6.2.tar.gz 1296198 BLAKE2B 4cd04b5e69788f2bbe3e87eafe6a7cf4f0a2e72abff4784176299e46943eac2219141beed2f8d11cc8a2458737456d8edaed42a5392bedd017e85315dc75ba1d SHA512 52c1464af82c09fc79338e805e62936d4da8131cea1bb6608500fa36a2d4069676eace5da0ed1b14d82de9d626be301b42c7bc1d5c620bbecb47ae9a350ecd65
47 changes: 47 additions & 0 deletions app-metrics/mongodb_exporter/mongodb_exporter-0.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit user golang-build golang-vcs-snapshot

EGO_PN=github.com/percona/mongodb_exporter
EXPORTER_COMMIT=a642618

DESCRIPTION="Prometheus exporter for MongoDB"
HOMEPAGE="https://github.com/percona/mongodb_exporter"
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

DEPEND="dev-util/promu"

pkg_setup() {
enewgroup ${PN}
enewuser ${PN} -1 -1 -1 ${PN}
}

src_prepare() {
default
sed -i -e "/-s$/d" -e "s/{{.Revision}}/${EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
}

src_compile() {
pushd src/${EGO_PN} || die
mkdir -p bin || die
GOPATH="${S}" promu build -v --prefix bin || die
popd || die
}

src_install() {
pushd src/${EGO_PN} || die
dobin bin/mongodb_exporter
dodoc {README,CHANGELOG}.md
popd || die
keepdir /var/log/mongodb_exporter
fowners ${PN}:${PN} /var/log/mongodb_exporter
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
}

0 comments on commit 63c350c

Please sign in to comment.