Skip to content

Commit

Permalink
dev-python/python-gnupg: Bump to 0.5.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 12, 2023
1 parent 8d9b068 commit 63dbdb6
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/python-gnupg/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST python-gnupg-0.5.1.tar.gz 64377 BLAKE2B bc17b2a21b44c2238ad528951ddcc43d4f607cace7bf9656329dfdba360090da5efe90425c0d3ff9e9d3c42655b996a3a5a31a1f90524457fe047ab46b272e27 SHA512 7be68c2f8aad0e0923fd27e53bbbfaea8fe7b3816ff231ab6a06a52efd3a4a594af27355abcf0a453e1d0556ad8c02e960ff7c84cb0ce7d053a1adc91131eea0
DIST python-gnupg-0.5.1.tar.gz.asc 801 BLAKE2B a3b34af465d412a35f8450b5de287764c2b516de8dc989a0654d136e77123db533792faaef2f1f7a246d4bf02783e23c84cf76cf404def1282edffa2d25ec73a SHA512 ecf1fd69030ec6dff5d0ffbbcaa9112d7b2d5d1badb76257c6cdf674cbc579e8bd9837f8e30943aa23c316d121926c4aa5e2f0b865ed55a6ba661c4b2642fd30
DIST python-gnupg-0.5.2.tar.gz 64531 BLAKE2B c753004e60c16d9c098074b44f1d0b71e35544b478fbd90bfce0e50ab72b8581229d540ea612327b1fde0bcb247782daf4c39c51efe4de3360faeadc13a22f80 SHA512 9ccfb1dad7895cd08b86f9d220a58d67d83a8acead830364d51d49733d442e7d36e8b68541f3f867a4f11c964293b084a316c1caeb45165af2882b8603742846
DIST python-gnupg-0.5.2.tar.gz.asc 801 BLAKE2B e778867bf354f6b488a2876bd70928642062200388227cae497cd09c934803a57801a2a306b669aa13aeaeb741f69b15c9597df2d19c04fb9137a1e6f20d36e8 SHA512 ea1d017331dcc88bda9bfa5332894a55e9597aabcecf9abdfd1ae8fa9e23478346d3c82d809fc1e34f112ace091c1d4cfb2bc67f33d30bd34dc0127055bb2065
48 changes: 48 additions & 0 deletions dev-python/python-gnupg/python-gnupg-0.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..12} )

inherit distutils-r1 verify-sig

DESCRIPTION="A Python wrapper for GnuPG"
HOMEPAGE="
https://docs.red-dove.com/python-gnupg/
https://github.com/vsajip/python-gnupg/
https://pypi.org/project/python-gnupg/
"
SRC_URI="
https://github.com/vsajip/python-gnupg/releases/download/${PV}/${P}.tar.gz
verify-sig? (
https://github.com/vsajip/python-gnupg/releases/download/${PV}/${P}.tar.gz.asc
)
"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
LICENSE="BSD"
SLOT="0"

# Need gnupg[nls] for avoiding decode errors and possible hangs
# w/ e.g. sec-keys/openpgp-keys-gentoo-developers but other pkgs too.
DEPEND="
app-crypt/gnupg[nls]
"
RDEPEND="
${DEPEND}
"
BDEPEND="
verify-sig? ( sec-keys/openpgp-keys-vinaysajip )
"

distutils_enable_tests unittest

VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/vinaysajip.asc

python_test() {
# NO_EXTERNAL_TESTS must be enabled,
# to disable all tests, which need internet access.
NO_EXTERNAL_TESTS=1 eunittest
}

0 comments on commit 63dbdb6

Please sign in to comment.