Skip to content

Commit

Permalink
x11-misc/lightdm: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
Markos Chandras committed Dec 10, 2016
1 parent c6e1425 commit 63e983f
Show file tree
Hide file tree
Showing 2 changed files with 137 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-misc/lightdm/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST lightdm-1.16.7.tar.xz 486692 SHA256 67b72a5dadf823ebc7df1bb523da59342271fcf
DIST lightdm-1.18.3.tar.xz 503968 SHA256 d99215aeca38db2da84eede2ac3b9e875a746b3bc81bb3a30e0b8d89b87e1494 SHA512 dde34e4969d2f04e6729eb1b30d38bac9a89ff42c46f8a21e94b76beadbde450ffaa377201bd3a56e0d8d95d0640eb312ed11ecf94efb9a5a66777b944d4f234 WHIRLPOOL 5b06581c56188ada75a196d0663b041b7507f0923a8a8ceec2531926a034675ac592df356c7840568492f5af9ca0d6058ad477904147ece66568f59517cde8cb
DIST lightdm-1.20.0.tar.xz 506488 SHA256 f03b7804a4902d189849a060292e4987d1e4f8272a1edb3e681e6f3cdfaa5ba4 SHA512 7d1d8379bc59f0326f486fe4a618c4939aadd6795ff92f9cd983997ad41e5fed5690eb6cbd81de30f4384ede6f5f88b2fff1781e13b51b5fe8f389379e8d2335 WHIRLPOOL e6345a1b66afb05aefe52664d33274df316b43d17808404cd7337dff284cb41106e191ffaf24e9805a02ac2b650d784fe988592a460a81302022386b2aadb674
DIST lightdm-1.21.1.tar.xz 515572 SHA256 c051f3d0cbfc96936b1ac83b73e2f1ad7daa0640067e9edd367edec81706c954 SHA512 f7a3437bf0ecd9a14e90f3930e98c3c088500b06b074347f620aeb80b7e48330e2bb84ac08cefff116bd6b84b1051cdfa29736045700d6571ffa2ba7b31f9eb3 WHIRLPOOL 5c1195bee4e4e8790b8a16383676dc9f2ce4d8f1cbf5dd092d6b6807a94d5f7e3b661c5506b5b128613280acd4109b8ad68009e54593050c20a3f390006e1002
DIST lightdm-1.21.3.tar.xz 517332 SHA256 f66d95d61672701ae8dca0b2d9fe52429e8c068bfbc598639a03a97ee4d0cc0b SHA512 bb91a1eae1d3637c1556b968b062cf9fc0c0f619320458ea77ea3c4f3dbf2aff5eeed136c703744851ec21fca8e0410dcfb02d2a44ca55c1f2db290a0bf3fde1 WHIRLPOOL 26e1ff294598b5648a0a6073ee68585698de41d38b2d77ca9deb2cbffc5beb685563e204ce5077b7ae945b253d68b08fb8580ac4e6220db92079af01c7419a2e
136 changes: 136 additions & 0 deletions x11-misc/lightdm/lightdm-1.21.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,136 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils flag-o-matic pam qmake-utils readme.gentoo-r1 systemd versionator xdg-utils

TRUNK_VERSION="$(get_version_component_range 1-2)"
DESCRIPTION="A lightweight display manager"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/LightDM"
SRC_URI="https://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.xz
mirror://gentoo/introspection-20110205.m4.tar.bz2"

LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="audit +gtk +introspection kde qt4 qt5 +gnome"
REQUIRED_USE="|| ( gtk kde )"

COMMON_DEPEND="audit? ( sys-process/audit )
>=dev-libs/glib-2.32.3:2
dev-libs/libxml2
gnome? ( sys-apps/accountsservice )
virtual/pam
x11-libs/libX11
>=x11-libs/libxklavier-5
introspection? ( >=dev-libs/gobject-introspection-1 )
qt4? (
dev-qt/qtcore:4
dev-qt/qtdbus:4
dev-qt/qtgui:4
)
qt5? (
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
)"
RDEPEND="${COMMON_DEPEND}
>=sys-auth/pambase-20101024-r2"
DEPEND="${COMMON_DEPEND}
dev-util/gtk-doc-am
dev-util/intltool
gnome? ( gnome-base/gnome-common )
sys-devel/gettext
virtual/pkgconfig"
PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
kde? ( x11-misc/lightdm-kde )"

DOCS=( NEWS )
RESTRICT="test"

src_prepare() {
xdg_environment_reset

sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die

einfo "Fixing the session-wrapper variable in lightdm.conf"
sed -i -e \
"/^#session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
data/lightdm.conf || die "Failed to fix lightdm.conf"

# use correct version of qmake. bug #566950
sed -i -e "/AC_CHECK_TOOLS(MOC4/a AC_SUBST(MOC4,$(qt4_get_bindir)/moc)" configure.ac || die
sed -i -e "/AC_CHECK_TOOLS(MOC5/a AC_SUBST(MOC5,$(qt5_get_bindir)/moc)" configure.ac || die

default

# Remove bogus Makefile statement. This needs to go upstream
sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
if has_version dev-libs/gobject-introspection; then
eautoreconf
else
AT_M4DIR=${WORKDIR} eautoreconf
fi
}

src_configure() {
# Set default values if global vars unset
local _greeter _session _user
_greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
_session=${LIGHTDM_SESSION:=gnome}
_user=${LIGHTDM_USER:=root}
# Let user know how lightdm is configured
einfo "Gentoo configuration"
einfo "Default greeter: ${_greeter}"
einfo "Default session: ${_session}"
einfo "Greeter user: ${_user}"

use qt5 && append-cxxflags -std=c++11

# also disable tests because libsystem.c does not build. Tests are
# restricted so it does not matter anyway.
econf \
--localstatedir=/var \
--disable-static \
--disable-tests \
$(use_enable audit libaudit) \
$(use_enable introspection) \
$(use_enable qt4 liblightdm-qt) \
$(use_enable qt5 liblightdm-qt5) \
--with-user-session=${_session} \
--with-greeter-session=${_greeter} \
--with-greeter-user=${_user}
}

src_install() {
default

# Delete apparmor profiles because they only work with Ubuntu's
# apparmor package. Bug #494426
if [[ -d ${D}/etc/apparmor.d ]]; then
rm -r "${D}/etc/apparmor.d" || die \
"Failed to remove apparmor profiles"
fi

insinto /etc/${PN}
doins data/{${PN},keys}.conf
doins "${FILESDIR}"/Xsession
fperms +x /etc/${PN}/Xsession
# /var/lib/lightdm-data could be useful. Bug #522228
dodir /var/lib/lightdm-data

prune_libtool_files --all
rm -rf "${ED}"/etc/init

# Remove existing pam file. We will build a new one. Bug #524792
rm -rf "${ED}"/etc/pam.d/${PN}{,-greeter}
pamd_mimic system-local-login ${PN} auth account password session #372229
pamd_mimic system-local-login ${PN}-greeter auth account password session #372229
dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163

readme.gentoo_create_doc

systemd_dounit "${FILESDIR}/${PN}.service"
}

0 comments on commit 63e983f

Please sign in to comment.