Skip to content

Commit

Permalink
dev-db/timescaledb: add 2.11.1
Browse files Browse the repository at this point in the history
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Jul 1, 2023
1 parent f672e16 commit 63ffaef
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/timescaledb/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST timescaledb-2.10.3.tar.gz 7465897 BLAKE2B 2a70e281738fac63cd3b5c753f82a7e8faf162c015ad87b1cb3b24558d70e042bb16281b32a931fbb4daae280bede40bc239de8e8b3228c2571da33d4e5975ec SHA512 c94227d9aa1df36634bbf2626f580165860cab543efbfeb448f9799cf70ef6c1891af0077c2280ae22dbfb2360cf2b6012e7f05c26b0cf7aef6eb217c583b444
DIST timescaledb-2.11.0.tar.gz 7699408 BLAKE2B 841ed5c95d15665a3d264067d7ae38ddecec4c2ae3cb4e6ddeb6b926b30453b0554a451117f939a7137abc1a1b3f0a0d0523782b337930984c76066355fe2457 SHA512 0bc1f7824fdac0a9014918bf053da3b282eaf6f91c18dec5ba4ec40204e29cb53d17f8d09c9426572969e2722b77788bb477a695d78f487415198cb3186d2cc2
DIST timescaledb-2.11.1.tar.gz 7723360 BLAKE2B a45f7a4466397b47e0a07cf9af388fa6c6ccbfd98d62a038159eafab74ba0c58b8891ebc52a82e9694f103cb48992c9b78c0b6f377c6ae7832fe8740c42d9bbf SHA512 e29a378bfe1e5bb72d6d9bd430b972d1e14cf2345f2599559f73075146fd8c5839f08459880681140eff607b152671beeb1876bf509008ad2b653d258eb356b8
67 changes: 67 additions & 0 deletions dev-db/timescaledb/timescaledb-2.11.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

POSTGRES_COMPAT=( 12 13 14 15 )
POSTGRES_USEDEP="ssl"

inherit postgres-multi cmake

DESCRIPTION="Open-source time-series SQL database"
HOMEPAGE="https://www.timescale.com/"
SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

IUSE="proprietary-extensions"
LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"

KEYWORDS="~amd64"

SLOT=0

RESTRICT="test"

DEPEND="${POSTGRES_DEP}"
RDEPEND="${DEPEND}"

CMAKE_IN_SOURCE_BUILD=yes
CMAKE_BUILD_TYPE="RelWithDebInfo"
BUILD_DIR=${WORKDIR}/${P}

src_prepare() {
postgres-multi_src_prepare
postgres-multi_foreach cmake_src_prepare
}

timescale_configure() {
local CMAKE_USE_DIR=$BUILD_DIR
local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )

# licensing is tied to features, this useflag disables the non-apache2 licensed bits
if ! use proprietary-extensions ; then
mycmakeargs+=("-DAPACHE_ONLY=ON")
fi
cmake_src_configure
}

src_configure() {
postgres-multi_foreach timescale_configure
}

timescale_src_compile() {
local CMAKE_USE_DIR=$BUILD_DIR
cmake_src_compile
}

src_compile() {
postgres-multi_foreach timescale_src_compile
}

timescale_src_install() {
local CMAKE_USE_DIR=$BUILD_DIR
cmake_src_install
}

src_install() {
postgres-multi_foreach timescale_src_install
}

0 comments on commit 63ffaef

Please sign in to comment.