Skip to content

Commit

Permalink
dev-ruby/cri: add ruby30
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Nov 2, 2021
1 parent 857ec64 commit 643a628
Showing 1 changed file with 32 additions and 0 deletions.
32 changes: 32 additions & 0 deletions dev-ruby/cri/cri-2.15.11-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby26 ruby27 ruby30"

RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"

RUBY_FAKEGEM_TASK_DOC="doc"

inherit ruby-fakegem

DESCRIPTION="Cri is a library for building easy-to-use commandline tools"
HOMEPAGE="https://rubygems.org/gems/cri"
LICENSE="MIT"

KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE=""

ruby_add_bdepend "doc? ( dev-ruby/yard )
test? ( dev-ruby/yard dev-ruby/minitest )"

all_ruby_prepare() {
sed -e '/coveralls/I s:^:#:' -i test/helper.rb || die
sed -i -e '/rubocop/ s:^:#:' \
-e '/RuboCop/,/end/ s:^:#:' Rakefile || die
}

each_ruby_test() {
${RUBY} -Ilib -S rake test_unit || die
}

0 comments on commit 643a628

Please sign in to comment.