Skip to content

Commit

Permalink
dev-cpp/benchmark: add 1.7.0
Browse files Browse the repository at this point in the history
Signed-off-by: Marek Szuba <[email protected]>
  • Loading branch information
Marek Szuba committed Jul 25, 2022
1 parent 9f7fac0 commit 644151d
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/benchmark/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST benchmark-1.6.1.tar.gz 184616 BLAKE2B bcbc69ae4c4f5f21ed8199f34faccf41a9b97d311aaeeba8cecb6acc47780c91d2cb41a1dadfe400accecd46f90f02211a219a0000739c122dc7398ae1fa76a7 SHA512 7d3e3baf5a2d92e9552ab5007c37253b3510ac269edf8922a2794ff3dfbd0bf5b4c519240d4577b1ec30ef9e8a64caa17a809054c3dc7f2b1bcd410596177d67
DIST benchmark-1.7.0.tar.gz 194165 BLAKE2B 2a5ae10fb1fd1d05da60287591a5ba16d9bf8f7c77d1f332a6482cba32841a00b1350bf83238d52e051bcf2f628ed8ffc9e1899c75337b8cd12d9fb1800fd5b0 SHA512 25f81930ce210e298d9cc67c965cc8937f66c53427b18a672338b86424eef32df877ec6b7a7106417464b29c5048b014fcc82cfa773168ed701aa47d01f39f82
36 changes: 36 additions & 0 deletions dev-cpp/benchmark/benchmark-1.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake flag-o-matic

DESCRIPTION="A microbenchmark support library"
HOMEPAGE="https://github.com/google/benchmark"
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
IUSE="debug doc lto test"

RESTRICT="!test? ( test )"

BDEPEND="doc? ( app-doc/doxygen )
test? ( >=dev-cpp/gtest-1.11.0 )"

src_configure() {
local mycmakeargs=(
-DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
-DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
-DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
-DBENCHMARK_ENABLE_LTO=$(usex lto)
-DBENCHMARK_ENABLE_TESTING=$(usex test)
-DBENCHMARK_ENABLE_WERROR=OFF
-DBENCHMARK_USE_BUNDLED_GTEST=OFF
)

use debug || append-cppflags -DNDEBUG

cmake_src_configure
}

0 comments on commit 644151d

Please sign in to comment.