Skip to content

Commit

Permalink
sys-libs/libapparmor: version bump 2.13.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Michael Palimaka <[email protected]>
  • Loading branch information
kensington committed Aug 4, 2019
1 parent 0a41c9d commit 649a9cc
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/libapparmor/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST apparmor-2.13.1.tar.gz 7367615 BLAKE2B 34a5f42b32bd4790f1075b76dfa17dd5b5cedfde7074eb0c57a3982a47e7b4dd2570bc056a4f4a8064c6a126a4727829cf5dcc04a4912f009338206faa887017 SHA512 e4b9788ecc0b59285f17d5e87669f507bf849c15d0ac3833e8d1d6aa2ece7add15814c75f257cea9d71a709c1af4990d8b76773e59fd42dbf5cfa2de0f9495a7
DIST apparmor-2.13.2.tar.gz 7369240 BLAKE2B 1e2a559375c02c7ab8e79cc2e9275a9f271490ef003a8da3e544bfdd80b47ddef7a7da0bf73b41e6fe9bff219a6e4fda7d04e6df71bb127530828160704cb7fe SHA512 2e5f84ced12c9de1a862e1a3258e8424f1f0d3c986947aec9d88a9258729a584953d00591c8902aa41e664acf9a639dab96d025c3a1ed3f91f0edce8d028b58f
DIST apparmor-2.13.3.tar.gz 7384974 BLAKE2B fd519f7b845db3203c8f47ff5abc7d9f20a7947fe86799b6fffcfaabaf5130fe0aa6589314f201c1df59cfd0fb22b80a12d364e9ca1279b14ba89ec469e3b346 SHA512 137b2bf026ec655b662e9c264d7d48d878db474a3f1cc5a38bfd7df2f85b682bddb77b091ab5595178231a0a262c9ae9cdd61409461cd889bdee156906ef1141
97 changes: 97 additions & 0 deletions sys-libs/libapparmor/libapparmor-2.13.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
GENTOO_DEPEND_ON_PERL="no"

inherit autotools distutils-r1 eapi7-ver perl-functions

MY_PV="$(ver_cut 1-2)"

DESCRIPTION="Library to support AppArmor userspace utilities"
HOMEPAGE="https://gitlab.com/apparmor/apparmor/wikis/home"
SRC_URI="https://launchpad.net/apparmor/${MY_PV}/${PV}/+download/apparmor-${PV}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc +perl +python static-libs"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="perl? ( dev-lang/perl:= )
python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
sys-devel/autoconf-archive
sys-devel/bison
sys-devel/flex
doc? ( dev-lang/perl )
perl? ( dev-lang/swig )
python? ( dev-lang/swig )"

S=${WORKDIR}/apparmor-${PV}/libraries/${PN}

PATCHES=( "${FILESDIR}/${PN}-2.10-symbol_visibility.patch" )

RESTRICT="test"

src_prepare() {
rm -r m4 || die "failed to remove bundled macros"
default
eautoreconf
use python && distutils-r1_src_prepare
}

src_configure() {
econf \
$(use_enable static-libs static) \
$(use_with perl) \
$(use_with python)
}

src_compile() {
emake -C src
emake -C include
use doc && emake -C doc
use perl && emake -C swig/perl

if use python ; then
pushd swig/python > /dev/null
emake libapparmor_wrap.c
distutils-r1_src_compile
popd > /dev/null
fi
}

src_install() {
emake DESTDIR="${D}" -C src install
emake DESTDIR="${D}" -C include install
use doc && emake DESTDIR="${D}" -C doc install

if use perl ; then
emake DESTDIR="${D}" -C swig/perl install
perl_set_version
insinto "${VENDOR_ARCH}"
doins swig/perl/LibAppArmor.pm

# bug 620886
perl_delete_localpod
perl_fix_packlist
fi

if use python ; then
pushd swig/python > /dev/null
distutils-r1_src_install

python_moduleinto LibAppArmor
python_foreach_impl python_domodule LibAppArmor.py
popd > /dev/null
fi

dodoc AUTHORS ChangeLog NEWS README

find "${D}" -name '*.la' -delete || die
}

0 comments on commit 649a9cc

Please sign in to comment.