Skip to content

Commit

Permalink
net-misc/cni-plugins: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
mrueg committed Sep 13, 2017
1 parent 7fee51f commit 64e2b75
Show file tree
Hide file tree
Showing 3 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/cni-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST cni-plugins-0.6.0.tar.gz 787756 SHA256 8589670f7f9b211a351dfcd211d4fe0b961d77283a7415443dc188f3dbf05668 SHA512 4b3c1901154eb1af86dc35888fda7b7666ee88d2cf728fb09182df5385d32b747de34c5c01598e1f37ae1e3497dbf5af2bc6ad6f737e683ccfccf9c1860cf6dc WHIRLPOOL 4e06c4b54144139509148cb851182dfa642fa4614fc392304bdc541611dc8bb34c978e9ff6507bb55a46a4d0f016feaf615abd09cdfb303e1f9e995162a19351
36 changes: 36 additions & 0 deletions net-misc/cni-plugins/cni-plugins-0.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit golang-vcs-snapshot

KEYWORDS="~amd64"
DESCRIPTION="Standard networking plugins for container networking"
EGO_PN="github.com/containernetworking/plugins"
HOMEPAGE="https://github.com/containernetworking/plugins"
SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="hardened"

src_compile() {
pushd src || die
local i
for i in plugins/{meta/{flannel,portmap,tuning},main/{bridge,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local},sample}; do
CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${WORKDIR}/${P}" go install -v "${EGO_PN}/${i}"
done
popd || die
}

src_install() {
exeinto /opt/cni/bin
doexe bin/*
pushd src/${EGO_PN} || die
dodoc README.md
local i
for i in plugins/{meta/{flannel,portmap,tuning},main/{bridge,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local},sample}; do
newdoc README.md ${i##*/}.README.md
done
popd || die
}
11 changes: 11 additions & 0 deletions net-misc/cni-plugins/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<name>Manuel Rüger</name>
<email>[email protected]</email>
</maintainer>
<upstream>
<remote-id type="github">containernetworking/plugins</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 64e2b75

Please sign in to comment.