Skip to content

Commit

Permalink
app-emulation/skopeo: version bump to 0.1.32
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Nov 27, 2018
1 parent bf9cd9d commit 64f2dea
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/skopeo/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST skopeo-0.1.22.tar.gz 1921286 BLAKE2B 141f78d14cb47494af9e55541eeaa973c9e2065d6dcdc73a6ee296fd160a981b88a4464ebf803df56378f9de7d812721eab877386a4b756e6b914d2c08e44aca SHA512 10ed4e577b07f672540ff86774b5c5b6b7531765fd36313b9e4e6bf974840fee98ede193014977c381b96875cb9147307ee690f4fc8dd4f97d87681d7fa2f4f2
DIST skopeo-0.1.30.tar.gz 2700275 BLAKE2B d80125e1be32f3b490f5d66caa5b1bd482dc2203d0c37824bd40d06e240c347468f9635623344e6f9badd9dbbeed59383d5ec8ad81a9b8e01284bc48114470f6 SHA512 05ea7c54f1de7ab9676903a973c8039520fa023f295c705e600d01520c0f300d255268e41b9c716dc4a1f01e951d9b73acf24d5a1bc891f694798a3eb085f061
DIST skopeo-0.1.31.tar.gz 2886364 BLAKE2B 9ef9eb4fdd722216f15e14de6702aa0dfe3331b83acb803221b8f76a36428749b6bc302cb3ea2772dd42aefc336a80ad823cfcda9fc054a01f672cf7464592a1 SHA512 660856d962310f0274f3c2507a9a5cbfd8ceb205a3d2fdf30ebde856602151917492082356f6031e5d041ce02e53e562e83cba58259cdc456363f7af56b2507b
DIST skopeo-0.1.32.tar.gz 4366298 BLAKE2B b358cb197475d693fa47cdfda738a78f70c9f59c5e3e61e55f3be21ea137640de2e9c61eb6437faca9a8f0e8dd6dda673e1cd645922a23533e6101eb326ef789 SHA512 c52eeee85aa01448c9742d4e415e3ce6f2e0ef4e26a55758202baecb573ad8e3efb94c762d4c303fb21b896998b32e19f919a7382dfd6b17df2a96d66d07267b
53 changes: 53 additions & 0 deletions app-emulation/skopeo/skopeo-0.1.32.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EGO_PN=github.com/containers/skopeo
COMMIT=e94b4f9
inherit golang-vcs-snapshot

DESCRIPTION="Command line utility foroperations on container images and image repositories"
HOMEPAGE="https://github.com/containers/skopeo"
SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
>=dev-libs/libassuan-2.4.3
>=sys-fs/btrfs-progs-4.0.1
>=sys-fs/lvm2-2.02.145"
DEPEND="${COMMON_DEPEND}
dev-go/go-md2man"
RDEPEND="${COMMON_DEPEND}"

S="${WORKDIR}/${P}/src/${EGO_PN}"

RESTRICT="test"

src_compile() {
local BUILDTAGS="containers_image_ostree_stub"
set -- env GOPATH="${WORKDIR}/${P}" \
go build -ldflags "-X main.gitCommit=${COMMIT}" \
-gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
-o skopeo ./cmd/skopeo
echo "$@"
"$@" || die
cd docs || die
for f in *.1.md; do
go-md2man -in ${f} -out ${f%%.md} || die
done
}

src_install() {
dobin skopeo
doman docs/*.1
insinto /etc/containers
newins default-policy.json policy.json
insinto /etc/containers/registries.d
doins default.yaml
keepdir /var/lib/atomic/sigstore
einstalldocs
}

0 comments on commit 64f2dea

Please sign in to comment.