Skip to content

Commit

Permalink
dev-python/oslo-rootwrap: 5.9.1 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
prometheanfire committed Nov 22, 2017
1 parent 98bcb9b commit 64f3a40
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-rootwrap/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST oslo.rootwrap-5.4.1.tar.gz 42202 SHA256 a76cf545515c1cf6d4d9b1a01a339c1356d1eb78ff3b2190e168dafead3c7e7d SHA512 71980ea266703c7880834cf75b69be9f7bee834a3be314f13ade1bb9903ecf6337237a32a1ed06d020c2fdd3807642af1dd676b6736052d4e57784942782d960 WHIRLPOOL 321a2e9774e3702015510d608e4e145d9fc69c4069865dd5215ad6e94e3692e7e56e029298e908fc007f487d54737d3cd4218dfc93d0625c6950edba45da56b2
DIST oslo.rootwrap-5.9.0.tar.gz 42352 SHA256 f8947b42d02ae26942f0c1166b410016c7e1796b00f00983f685e9eccb91ba91 SHA512 5c299b8701d308f0f02a8edde08d56145781dfe9d25f4b064b2ce926e38a0be5a5dab20d6d57ebaf289af2758d97b81089407e1851edaca23c36436abf8433fd WHIRLPOOL 94ada80d8cf286fd20786106f37ac3579d387157a8125bd74f819b3fbccb31cbd5a00117507e836609c5dcaa64ce6983cd179aa8cd82333fdffeac7f0ddc3d5b
DIST oslo.rootwrap-5.9.1.tar.gz 42056 SHA256 11df3567e52f4cfd77e498713248f981c95a0cf01511610dd3bcc604c576799e SHA512 1c2505970217676954948546bd161a9038504f14ee3425c4d9a91807abe0e282e8e44c493c3d20e2e1c17ae506f3b768cf87c75ee46a0194c360663856796460 WHIRLPOOL 1b5f892d7d222e3ab7a1c3f1ee3fc3c18f11766ed085eb83bfb726d2e114623bd6806429a81dda63014874e8d215b48852ee19deb01ba6e33b6b663050f55caf
49 changes: 49 additions & 0 deletions dev-python/oslo-rootwrap/oslo-rootwrap-5.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
S="${WORKDIR}/oslo.rootwrap-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="test"

CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
>=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
<dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
>=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
!~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"

python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}

python_test() {
sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
nosetests tests/ || die "test failed under ${EPYTHON}"
}

0 comments on commit 64f3a40

Please sign in to comment.