forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ruby/actionpack-xml_parser: add 2.0.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
31 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST actionpack-xml_parser-1.0.2.tar.gz 6623 SHA256 6bed4e15ba11ed4bb33eacae77f15b78a78a0b81a6196203377208d5785178a2 SHA512 6fb9323b2632059d6c253083dfe6a09c413d4a5f7d622457402db95529ccad6d28b0471b01f4555c4e448b65183e6d07ef639de994c47c4858d2bfe5318aaa0b WHIRLPOOL 48f3fccf9207840ac1459026ea094f4c72af68e4b7904a21c9db40f735f9f9ccef5be84bc47e7687ee424ebcde17d3553db95eb2cf88cfe05a0fafbbe46b2e55 | ||
DIST actionpack-xml_parser-2.0.0.tar.gz 6499 SHA256 f2aafb0c9e935ce6b7b25a8c947d46fef4dd091e145b6f93cb8a7d7d4d638a5d SHA512 fb1a9c551a3ff6751e0b9e95b1c667ef5dd6da50b4e5cf4d010468f76d022cb437b20a02e8ee795da757de98e3e45e8b71b9f37f2c0dc16f1a338f8d335d712f WHIRLPOOL 6e30ed00ab7a579bef827ed52276a8fb98a0f95b90dc8408e72b98d910d08645ec4c06e42a54e4b5b3c077501847176638112c0b8694919b5ca72138e4ae7435 | ||
DIST actionpack-xml_parser-2.0.1.tar.gz 6494 SHA256 d9e43954a605dc712b1cd080db94c26da09cc4c4fe2ce1ad087d47609035b841 SHA512 a240e59178722025a0c967cfc2f63ca1ed8a2aff55ad913652f06018b712a7009eecd915f494dc4087de12ad5dbe5a0f3c7290fc530a2e475b39318520809112 WHIRLPOOL 34acdf10558f03ce461506ce8097e2795eb6e2a5262cae7c26bf554b933095dfbe58f17af11dd06bddf3372258b3b786d859309a3810a6bd5ab307a947c955f6 |
30 changes: 30 additions & 0 deletions
30
dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
USE_RUBY="ruby22 ruby23" | ||
|
||
RUBY_FAKEGEM_TASK_DOC="" | ||
|
||
inherit ruby-fakegem | ||
|
||
DESCRIPTION="XML parameters parser for Action Pack (removed from core in Rails 4.0)" | ||
HOMEPAGE="https://github.com/rails/actionpack-xml_parser" | ||
SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
|
||
KEYWORDS="~amd64" | ||
SLOT="2" | ||
IUSE="" | ||
|
||
ruby_add_rdepend "=dev-ruby/actionpack-5*:* =dev-ruby/railties-5*:*" | ||
|
||
all_ruby_prepare() { | ||
sed -i -e "/bundler/d" Rakefile test/helper.rb || die | ||
sed -i -e '1igem "actionpack", "~>5.0"' test/helper.rb || die | ||
} | ||
|
||
each_ruby_test() { | ||
${RUBY} -Ilib:.:test -e "Dir['test/*_test.rb'].each{|f| require f}" | ||
} |