forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gui-libs/gdk-pixbuf-loader-webp: add 0.0.5
Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gdk-pixbuf-loader-webp-0.0.4.tar.gz 23252 BLAKE2B d57aec7af7a5077caab054399a7b69b828680d16adc043ad420ea24648ae07c4879063479e5317cc35929f0b1f31fabc97a2ec32cda9d80f5ad64f07ad99c987 SHA512 2d67a0d56f248ae48b3f3500859cccf8fd358d0377c3a65e17018f849d77d28ac9ecc471709a84502baf26284e4dd5d9ef3045270de60de6be8e276eb4e54780 | ||
DIST gdk-pixbuf-loader-webp-0.0.5.tar.gz 23485 BLAKE2B 2f99ab14c25cc1caee9532c32d565203748bc8c8881d8d5efb5763705efc43c7f98f9f109d98c996f140038fffe07a7567e20bc2b79ab68990233df812649f58 SHA512 62fa485c1cdd50112eb88e53b78408f79bb8196549398d47982d0b467ed7efa8c0cf3263822faf42505a4e641330473e90f25f3d528393b378e1ac673642350b |
45 changes: 45 additions & 0 deletions
45
gui-libs/gdk-pixbuf-loader-webp/gdk-pixbuf-loader-webp-0.0.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit gnome2-utils meson-multilib | ||
|
||
DESCRIPTION="WebP GDK Pixbuf Loader library" | ||
HOMEPAGE="https://github.com/aruiz/webp-pixbuf-loader" | ||
SRC_URI="https://github.com/aruiz/webp-pixbuf-loader/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/webp-pixbuf-loader-${PV}" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
>x11-libs/gdk-pixbuf-2.22.0:2[${MULTILIB_USEDEP}] | ||
>media-libs/libwebp-0.4.3:=[${MULTILIB_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
default | ||
# Drop handling of pixbuf cache update by upstream | ||
sed -e '/query_loaders/d' -i meson.build || die | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_gdk_pixbuf_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
# causes segfault if set, see bug 375615 | ||
unset __GL_NO_DSO_FINALIZER | ||
multilib_foreach_abi gnome2_gdk_pixbuf_update | ||
} | ||
|
||
pkg_postrm() { | ||
# causes segfault if set, see bug 375615 | ||
unset __GL_NO_DSO_FINALIZER | ||
multilib_foreach_abi gnome2_gdk_pixbuf_update | ||
} |