Skip to content

Commit

Permalink
net-analyzer/nessus-agent-bin: version bump to 7.0.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
Marek Szuba committed Dec 19, 2017
1 parent b83867d commit 6542245
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-analyzer/nessus-agent-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST NessusAgent-6.11.2-es7.x86_64.rpm 15539504 BLAKE2B 1e03c2716200d88d600d2085adcbad6038a9b1aff1d4c80c291ba2609102fa34af43fabdceece545de9496f515252fcefd3ff6c8e13511635c7a6aa25bb146a3 SHA512 4ce8c8bf1ca8137712a796ddf5a39f139287789a6b966241b0f5831ee69bccdff5519c8fb821a043d00c5014f456a0f941e0d2de278383a49ddd73a0f6c18a2a
DIST NessusAgent-7.0.0-es7.x86_64.rpm 15595940 BLAKE2B a5796aca8efd3a0fa5191437bd055cae817a7a498cf6149d757f28acf268814652295f92b4cf5351b71175e1b498b59fe18e77a2cfaa7e253a53aa889b6677cd SHA512 10cce476f8ba822b0e5fc1dc7f47f3a531b0ac48553e769f18b14641bc1e323be3940e6712e7a2c4286f8b874cbf7dd02f85fd283da109a30864be875bedbfd9
64 changes: 64 additions & 0 deletions net-analyzer/nessus-agent-bin/nessus-agent-bin-7.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit rpm pax-utils systemd

MY_P="NessusAgent-${PV}-es7"

DESCRIPTION="A remote security scanner for Linux - agent component"
HOMEPAGE="https://www.tenable.com/"
SRC_URI="${MY_P}.x86_64.rpm"

LICENSE="GPL-2 Nessus-EULA"
SLOT="0"
KEYWORDS="~amd64"

RESTRICT="mirror fetch strip"

QA_PREBUILT="opt/nessus_agent/bin/nasl
opt/nessus_agent/bin/nessus-mkrand
opt/nessus_agent/lib/nessus/libjemalloc.so.${PV}
opt/nessus_agent/lib/nessus/libnessus-glibc-fix.so
opt/nessus_agent/lib/nessus/plugins/ovaldi64-rhel7.inc
opt/nessus_agent/sbin/nessus-check-signature
opt/nessus_agent/sbin/nessus-service
opt/nessus_agent/sbin/nessuscli
opt/nessus_agent/sbin/nessusd"

S="${WORKDIR}"

pkg_nofetch() {
einfo "Please download ${A} from ${HOMEPAGE}/agent-download"
einfo "The archive should then be placed into ${DISTDIR}."
}

src_install() {
# Using doins -r would strip executable bits from all binaries
cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"

pax-mark m "${D}"/opt/nessus_agent/sbin/nessusd

# Make sure these originally empty directories do not vanish,
# Nessus will not run properly without them
keepdir /opt/nessus_agent/com/nessus/CA
keepdir /opt/nessus_agent/etc/nessus
keepdir /opt/nessus_agent/var/nessus/logs
keepdir /opt/nessus_agent/var/nessus/tmp
keepdir /opt/nessus_agent/var/nessus/users

newinitd "${FILESDIR}"/nessusagent.initd nessusagent
systemd_dounit usr/lib/systemd/system/nessusagent.service
}

pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog "In order to link the agent to Tenable.io or an instance of Nessus Manager,"
elog "obtain an appropriate linking key and run"
elog ""
elog " /opt/nessus_agent/sbin/nessuscli agent link --key=<key> --host=<host> --port=<port> [optional parameters]"
elog ""
elog "This can be done before the agent is started."
fi
}

0 comments on commit 6542245

Please sign in to comment.