Skip to content

Commit

Permalink
app-admin/hcloud: add 1.44.1
Browse files Browse the repository at this point in the history
Signed-off-by: Agostino Sarubbo <[email protected]>
  • Loading branch information
asarubbo committed Jul 1, 2024
1 parent 21c82ef commit 655e47e
Show file tree
Hide file tree
Showing 2 changed files with 32 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/hcloud/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST hcloud-1.43.1.tar.xz 1889004 BLAKE2B 563cde962cf1fd180bbef60127b714419c09da198afeb4923f8fc1cd48850131b3b91de243de43e269497f36d14757a1e71941d30dfbee98baebb533f20e6cdd SHA512 c8fa46e9d3e2c73cc2d86e597bebf6e1dbf28b7145dbc272c403607807251ac27eee14b9ad267fdf2aa730da16ce52be4d2b0d94653612b4f375f1779c95d90b
DIST hcloud-1.44.0.tar.xz 2198712 BLAKE2B 120960528a1ef82993acd6ce791dd2f7a47968ab933f896e0d19df2d85b1453d3a4c7cbf6482aa0f051a6bcdd90a1ce34d7ff22ae10162c09b96b7afac9387bd SHA512 7fc6a4c531f991fc96decc79aa869bd875167a741630e86801bdc538877d372183f8ee34e2e4d683230f556573df01ab6f87f30cde6a43ffe70da1437bcfcd2d
DIST hcloud-1.44.1.tar.xz 2198900 BLAKE2B 48c6e8bacc66a54cb111ce196ccbcdb1ed6f867a5fce21eef02d73a81ee4c7d7398720e28f6d4d120beceb29b0178039d42a4ac1f1c3a4700e4e894265c36a14 SHA512 9086af42f7b30dbaae350937e58afcc85c717d39ac0a5e42b00a47266293de047b9906705ad7d0f5bee92cae1a151308467c03bdadef8077351050090a063131
31 changes: 31 additions & 0 deletions app-admin/hcloud/hcloud-1.44.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

DESCRIPTION="A command-line interface for Hetzner Cloud"
HOMEPAGE="https://github.com/hetznercloud/cli"
SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

src_compile() {
ego build -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.versionPrerelease=gentoo" ./cmd/${PN}
}

src_test() {
# For upstream a simple test is run 'hcloud version'
./hcloud version
if [[ $? -ne 0 ]]
then
die "Test failed"
fi
}

src_install() {
dobin ${PN}
}

0 comments on commit 655e47e

Please sign in to comment.