forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-crypt/eid-mw: version bump 4.4.1
Submitted-by: Vincent Hardy <[email protected]> Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
93 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST eid-mw-4.2.5.tar.gz 7751526 BLAKE2B 4836dc3a5ba4d781b8c342231cbbe74411fc6f0bf4b32eaa42ac28ea7688815361f74a1def371a05e250d3249af7ff58d24a66062fe169717872d6789ffb54f1 SHA512 cf00f6aa295c3d057e77faddde31ba6b00ce44402bc0ad141c773fb58067d7cf2e107fc5f3a294be8731de592cb0895537cd29ad4e69f6721e6c77fa99c12075 | ||
DIST eid-mw-4.2.8.tar.gz 7076407 BLAKE2B e1d9b375adb326cb710da9eb5cd125086cb40b6ee37ce2ac3912ac4b5fa9c92d66c8af002a47c9ce73ff98ad2306e96529e1c87486eb0f36e61a1f4eb2231b9f SHA512 bf910e8b5bad40fe65765524af20cf18e2c615b6b7bddfdd3024309d90767952875f1c264ea8bd8dfc73621a41683fce02501febe71c016816ccc0f75d88d8cb | ||
DIST eid-mw-4.3.6.tar.gz 7515482 BLAKE2B 8895564736be83ad2f9797a6cfcbc6cb50a928c36508b9ddcf8e9032d7b4de9284745d711a7664edba106ad005a63eb1fddb5c1e639305b4af12f49ab8dbc61c SHA512 336181c21896bec0e7a0a67f5bc739fdc63ca7b17eb6fefa98b6d468810fcdb52ecb6a64f267cdcfc063a2ef599d033064ec90b6bb41ec7ceccc2ca8e829a82b | ||
DIST eid-mw-4.4.1.tar.gz 7708697 BLAKE2B 7bdbaa37af1cdd5a8abd1519939f663c7c871cea49850932d97c391465de362885b061c024285ab2690473a4bb1ba57a70fdc12a720246b2a610ac9525f6395e SHA512 9de54858ac052eeff101070dd11c5cf60ab1d29b8dc8d946680745acf9aa6ba1044ca5451eca6066b5b467fbc32a2a23bbe7e8551ca7559e6003a4097a304cfc |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,92 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools gnome2-utils | ||
|
||
DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal Government" | ||
HOMEPAGE="https://eid.belgium.be" | ||
SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} -> ${P}.tar.gz" | ||
|
||
LICENSE="LGPL-3" | ||
SLOT="0" | ||
KEYWORDS="~x86 ~amd64 ~arm" | ||
IUSE="+dialogs +gtk p11-kit" | ||
|
||
RDEPEND=">=sys-apps/pcsc-lite-1.2.9 | ||
gtk? ( | ||
x11-libs/gdk-pixbuf[jpeg] | ||
x11-libs/gtk+:* | ||
dev-libs/libxml2 | ||
net-misc/curl[ssl] | ||
net-libs/libproxy | ||
!app-misc/eid-viewer-bin | ||
) | ||
p11-kit? ( app-crypt/p11-kit )" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
REQUIRED_USE="dialogs? ( gtk )" | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die | ||
sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die | ||
|
||
# Buggy internal versioning when autoreconf a tarball release. | ||
# Weird numbering is required otherwise we get a seg fault in | ||
# about-eid-mw program. | ||
echo "${PV}-v${PV}" > .version | ||
sed -i \ | ||
-e '/^GITDESC/ d' \ | ||
-e '/^VERCLEAN/ d' \ | ||
scripts/build-aux/genver.sh | ||
|
||
# legacy xpi module : we don't want it anymore | ||
sed -i -e 's:plugins_tools/xpi$::' Makefile.am || die | ||
sed -i -e '/plugins_tools\/xpi/ d' configure.ac || die | ||
|
||
# hardcoded lsb_info | ||
sed -i \ | ||
-e "s:get_lsb_info('i'):strdup(_(\"Gentoo\")):" \ | ||
-e "s:get_lsb_info('r'):strdup(_(\"n/a\")):" \ | ||
-e "s:get_lsb_info('c'):strdup(_(\"n/a\")):" \ | ||
plugins_tools/aboutmw/gtk/about-main.c || die | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
$(use_enable dialogs) \ | ||
$(use_enable p11-kit p11kit) \ | ||
$(use_with gtk gtkvers 'detect') \ | ||
--with-gnu-ld \ | ||
--disable-static | ||
} | ||
|
||
src_install() { | ||
default | ||
rm -r "${ED}"/usr/$(get_libdir)/*.la || die | ||
if use gtk; then | ||
domenu plugins_tools/eid-viewer/eid-viewer.desktop | ||
doicon plugins_tools/eid-viewer/gtk/eid-viewer.png | ||
fi | ||
} | ||
|
||
pkg_postinst(){ | ||
if use gtk; then | ||
gnome2_schemas_update | ||
gnome2_icon_cache_update | ||
fi | ||
} | ||
|
||
pkg_postrm(){ | ||
if use gtk; then | ||
gnome2_schemas_update | ||
gnome2_icon_cache_update | ||
fi | ||
} |