Skip to content

Commit

Permalink
dev-java/java-config: version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Jun 23, 2020
1 parent 36edf22 commit 65751b9
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/java-config/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST java-config-2.2.0.tar.bz2 51851 BLAKE2B 7b7c15dc988d2f5f54ebacba224f57193577e24f99a798657b40d83d723280562e314ba71319958a83be44defc6a48ac1114cce37eaeddea025ea31f26cf331a SHA512 a491cfe86bde8afadfc5b875740d79f9077526d8650ffb034fdad67a7ffa1b02646f67b1ef0eab7b0fe3ae57b5d767fa6a0d5593fe07416993d60588a8ed595a
DIST java-config-2.3.1.tar.gz 26165 BLAKE2B 948506663513db369d0ed8ffdfaa54c643989431430ea03440551a6a4b6725d8eec38f5cb4fde3b64e8936c0f43de0e65a7368469032c646c7b6b3bb7ec3ed13 SHA512 62db555b2d8a37a03b6a03aa133010848d54be33ba6e3c43807abefe665a9d8ff2790baf1af79b98d4a7bd3e9ba6bc64382a24c3fcf7038338123dabd146b7b4
DIST java-config-2.3.tar.gz 26586 BLAKE2B 00fbc9bd606cb87bfde9f72837a062de540465a0299393016fc34543b89cf381a85b68ec5a884c0f76fe6b3188aa27498ed93e858187f2e51f6a23a2dcea7b67 SHA512 06e7c1ffe3fa0b903c5444ddcb9f72052773870c6543122440089a24bf0d8ec6c475e5f72a7ee9c3790432fdfeb786976af28e8aa7d18484168af16f5bb1b2ea
39 changes: 39 additions & 0 deletions dev-java/java-config/java-config-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

# jython depends on java-config, so don't add it or things will break
PYTHON_COMPAT=( python3_{6,7,8} )
DISTUTILS_USE_SETUPTOOLS=no

inherit distutils-r1

DESCRIPTION="Java environment configuration query tool"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

DEPEND="test? ( sys-apps/portage[${PYTHON_USEDEP}] )"

# baselayout-java is added as a dep till it can be added to eclass.
RDEPEND="
!dev-java/java-config-wrapper
sys-apps/baselayout-java
sys-apps/portage[${PYTHON_USEDEP}]"

python_install_all() {
distutils-r1_python_install_all

# This replaces the file installed by java-config-wrapper.
dosym java-config-2 /usr/bin/java-config
}

python_test() {
esetup.py test
}

0 comments on commit 65751b9

Please sign in to comment.