forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-vcs/mercurial: Bump to version 3.9.1
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Sep 2, 2016
1 parent
4f20ecc
commit 6596c34
Showing
2 changed files
with
136 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST mercurial-3.7.3.tar.gz 4636732 SHA256 c099c42d74e2d520b61dd372cd996b0fa7605c06617834fd7b13c79b9a9a5b30 SHA512 7f9f97229e40c7092c16ccf227b19a08a9839d8ce19a9d057341fff75876bff32241ee9aa10eab293f779ea3e8a1d97577597187bd96251fb499cbb1075a82cf WHIRLPOOL 51d7f152a0af27924fec8b39933796f5584867efff7f271147139e740302d05f8976f3c2aa95cb724b774ba4951040483bb51b02eed1495d8b15012301ba060e | ||
DIST mercurial-3.8.4.tar.gz 4775341 SHA256 4b2e3ef19d34fa1d781cb7425506a05d4b6b1172bab69d6ea78874175fdf3da6 SHA512 2ee785f631f9ae346e10ca77251a9ce6d3dacd598588c39f1a69ce1f4b668866f6109d682428512c37c300b26741b74672195538d66845e85cfff5ead886cf4c WHIRLPOOL 1f0a12cc6d00f3544ab00e011a9ff9308fe1652c0598045ddba2a41ba17b55c291da200bce85d4c600d673b8746e936c441ffa7398ad810d1069bd97fb32f2db | ||
DIST mercurial-3.9.1.tar.gz 4797967 SHA256 625e4fc7e85ec2278c2828bdc547fce74091b3bbe4d9eeeba2d61af51195df74 SHA512 d96e45cafd36be692d6ce5259e18140641c24f73d4731ff767df0f39af425b0630c687436fc0f53d5882495ceacacaadd5e19f8f7c701b4b94c48631123b4666 WHIRLPOOL ba4e9374b592d294767046fe7d4297df837d9e92ea2279a7a3654054c058a6b994cade2358d2c35a7d30b6985abd0f7afe55af586ccafbe1dc5b50059bc2712f | ||
DIST mercurial-3.9.tar.gz 4796280 SHA256 834f25dcff44994198fb8a7ba161a6e24204dbd63c8e6270577e06e6cedbdabc SHA512 148d5f4c1c8c78b654b03d898f8e9624697caf3f75ff8d56496f8ba5b0e28c487f6800ea2e7e26bf2ac5f01e9bdf92e7d3b4941c88521372af090a3587a0227b WHIRLPOOL e9aeddb4e660da53bf7db45472d1f6bd6ea4772ea590ec0c359bba5bb4c51cd2e26c0792c35ab9d311a83556e8e785ed8ebdad53adacf07e9450eaa98b9ce183 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,135 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
PYTHON_REQ_USE="threads" | ||
|
||
inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic | ||
|
||
DESCRIPTION="Scalable distributed SCM" | ||
HOMEPAGE="https://www.mercurial-scm.org/" | ||
SRC_URI="https://www.mercurial-scm.org/release/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
IUSE="bugzilla emacs gpg test tk" | ||
|
||
RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] ) | ||
gpg? ( app-crypt/gnupg ) | ||
tk? ( dev-lang/tk ) | ||
app-misc/ca-certificates" | ||
DEPEND="emacs? ( virtual/emacs ) | ||
test? ( app-arch/unzip | ||
dev-python/pygments[${PYTHON_USEDEP}] )" | ||
|
||
SITEFILE="70${PN}-gentoo.el" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" ) | ||
|
||
python_prepare_all() { | ||
# fix up logic that won't work in Gentoo Prefix (also won't outside in | ||
# certain cases), bug #362891 | ||
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_configure_all() { | ||
strip-flags -ftracer -ftree-vectorize | ||
# Note: make it impl-conditional if py3 is supported | ||
append-flags -fno-strict-aliasing | ||
|
||
"${PYTHON}" setup.py build_mo || die | ||
} | ||
|
||
python_compile_all() { | ||
rm -r contrib/{win32,macosx} || die | ||
if use emacs; then | ||
cd contrib || die | ||
elisp-compile mercurial.el || die "elisp-compile failed!" | ||
fi | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
|
||
newbashcomp contrib/bash_completion hg | ||
|
||
insinto /usr/share/zsh/site-functions | ||
newins contrib/zsh_completion _hg | ||
|
||
rm -f doc/*.?.txt | ||
dodoc CONTRIBUTORS | ||
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die | ||
|
||
dobin hgeditor | ||
dobin contrib/hgk | ||
python_foreach_impl python_doscript contrib/hg-ssh | ||
|
||
if use emacs; then | ||
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!" | ||
elisp-site-file-install "${FILESDIR}"/${SITEFILE} | ||
fi | ||
|
||
local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9 | ||
*.el mercurial.spec) | ||
for f in ${RM_CONTRIB[@]}; do | ||
rm -r contrib/$f || die | ||
done | ||
|
||
dodoc -r contrib | ||
docompress -x /usr/share/doc/${PF}/contrib | ||
doman doc/*.? | ||
|
||
insinto /etc/mercurial/hgrc.d | ||
doins "${FILESDIR}/cacerts.rc" | ||
} | ||
|
||
src_test() { | ||
pushd tests &>/dev/null || die | ||
rm -rf *svn* # Subversion tests fail with 1.5 | ||
rm -f test-archive* # Fails due to verbose tar output changes | ||
rm -f test-convert-baz* # GNU Arch baz | ||
rm -f test-convert-cvs* # CVS | ||
rm -f test-convert-darcs* # Darcs | ||
rm -f test-convert-git* # git | ||
rm -f test-convert-mtn* # monotone | ||
rm -f test-convert-tla* # GNU Arch tla | ||
#rm -f test-doctest* # doctest always fails with python 2.5.x | ||
rm -f test-largefiles* # tends to time out | ||
|
||
popd &>/dev/null || die | ||
distutils-r1_src_test | ||
} | ||
|
||
python_test() { | ||
local TEST_DIR | ||
|
||
rm -rf "${TMPDIR}"/test | ||
distutils_install_for_testing | ||
cd tests || die | ||
"${PYTHON}" run-tests.py --verbose \ | ||
--tmpdir="${TMPDIR}"/test \ | ||
--with-hg="${TEST_DIR}"/scripts/hg \ | ||
|| die "Tests fail with ${EPYTHON}" | ||
} | ||
|
||
pkg_postinst() { | ||
use emacs && elisp-site-regen | ||
|
||
elog "If you want to convert repositories from other tools using convert" | ||
elog "extension please install correct tool:" | ||
elog " dev-vcs/cvs" | ||
elog " dev-vcs/darcs" | ||
elog " dev-vcs/git" | ||
elog " dev-vcs/monotone" | ||
elog " dev-vcs/subversion" | ||
} | ||
|
||
pkg_postrm() { | ||
use emacs && elisp-site-regen | ||
} |