forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST boto3-1.35.0.gh.tar.gz 851637 BLAKE2B 485b17616fed53a88280aad92d2e4219d8bcbf469b42cff6113f9596c6b245fad39b403b4fb29ed99b50955baa50940091e9c0f88cc6e350b44c69c4b1df5fdc SHA512 0236748c667ef1baf7484d4808083cb517c19ceae672973ac0cf9ce509a9e4a965c15349876807dc320fc96210ba6c5d16ea66545de19eed33dace058392d85d | ||
DIST boto3-1.35.10.gh.tar.gz 856679 BLAKE2B 03e7be74455b487a79188405796fc08bd940962ca4ef8c36398ee8f955c2677e57a528626ef31e5e54ce2c1b96c82cef857b54dcc16248178c60c14fd14de3f9 SHA512 99c0e0b67a590a06713eeb98eb485b055ee6fa1bd181f996d24bdf88698d7885efe0a5f1e9883083655b12a474112a03f8561c66c4c5b5a0e6db56d5733db77b | ||
DIST boto3-1.35.11.gh.tar.gz 857616 BLAKE2B ffec2fc8c2a0c12d21ac84e6cbe0ea967e83aab3764720046dcbb16ad7af6bcb8fcefe1e5686be0b2442cb0ebe58c5b5e9b3c41c38292069b0115c7d6cd00616 SHA512 4b6a494737be338ef81581de6372605bb75c99dcd83bb905af460d50deb3c2cbb929f0f89cf46e53d92dd302eb387baf7c0d898e5aecf96bafc8b099c75a9e0b | ||
DIST boto3-1.35.5.gh.tar.gz 854016 BLAKE2B f94d738e310725cd5f9c7b405a094155f3ecf640f02045662ed94ab3689ea549fde7eee19ae2be450768560ad705b8740fda78b79ed42cf536231626d247e09a SHA512 fc1106abbb306bacb80dce825bf71303e71b0d0698d7e3bb4dcaca4ea6e4f7a97e70753367200294f334b351e764bca57f2316afec854d2e46db4644dfefc25b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{10..13} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="The AWS SDK for Python" | ||
HOMEPAGE=" | ||
https://github.com/boto/boto3/ | ||
https://pypi.org/project/boto3/ | ||
" | ||
SRC_URI=" | ||
https://github.com/boto/boto3/archive/${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
|
||
RDEPEND=" | ||
>=dev-python/botocore-${PV}[${PYTHON_USEDEP}] | ||
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}] | ||
>=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}] | ||
" | ||
|
||
EPYTEST_XDIST=1 | ||
distutils_enable_tests pytest | ||
|
||
python_prepare_all() { | ||
# don't lock versions to narrow ranges | ||
sed -e '/botocore/ d' \ | ||
-e '/jmespath/ d' \ | ||
-e '/s3transfer/ d' \ | ||
-i setup.py || die | ||
|
||
# do not rely on bundled deps in botocore (sic!) | ||
find -name '*.py' -exec sed -i \ | ||
-e 's:from botocore[.]vendored import:import:' \ | ||
-e 's:from botocore[.]vendored[.]:from :' \ | ||
{} + || die | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 | ||
epytest tests/{functional,unit} | ||
} |