forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/DBIx-Class-UserStamp: -r bump for EAPI7 + fixes
- EAPI7 - Unconditionally patch out bad tests - Convert "sed" hack to a patch Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <[email protected]>
- Loading branch information
1 parent
e0aec92
commit 662a34b
Showing
2 changed files
with
56 additions
and
0 deletions.
There are no files selected for viewing
35 changes: 35 additions & 0 deletions
35
dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
DIST_AUTHOR=JGOULAH | ||
DIST_VERSION=0.11 | ||
inherit perl-module | ||
|
||
DESCRIPTION="Automatically set update and create user id fields" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
dev-perl/Class-Accessor-Grouped | ||
dev-perl/DBIx-Class-DynamicDefault | ||
dev-perl/DBIx-Class | ||
" | ||
BDEPEND="${RDEPEND} | ||
test? ( dev-perl/DBD-SQLite ) | ||
" | ||
PERL_RM_FILES=( | ||
t/02pod.t | ||
t/03podcoverage.t | ||
) | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-0.11-no-dot-inc.patch" | ||
) | ||
|
||
# Parallel tests fail sometimes due to sharing a sqlite db path | ||
# and recreating the same table | ||
DIST_TEST="do" |
21 changes: 21 additions & 0 deletions
21
dev-perl/DBIx-Class-UserStamp/files/DBIx-Class-UserStamp-0.11-no-dot-inc.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
From 4a2406d0013f5f7fac7d008eba7fcb77e618d9a7 Mon Sep 17 00:00:00 2001 | ||
From: Kent Fredric <[email protected]> | ||
Date: Tue, 14 Jul 2020 08:15:59 +1200 | ||
Subject: Include '.' in @INC on perl 5.26 | ||
|
||
--- | ||
Makefile.PL | 1 + | ||
1 file changed, 1 insertion(+) | ||
|
||
diff --git a/Makefile.PL b/Makefile.PL | ||
index 4fff0bd..42fe07d 100644 | ||
--- a/Makefile.PL | ||
+++ b/Makefile.PL | ||
@@ -1,3 +1,4 @@ | ||
+use lib '.'; | ||
use inc::Module::Install; | ||
|
||
name 'DBIx-Class-UserStamp'; | ||
-- | ||
2.27.0 | ||
|