Skip to content

Commit

Permalink
dev-python/urllib3: Bump to 2.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 4, 2023
1 parent 026afb4 commit 6631faf
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/urllib3/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST urllib3-1.26.15.tar.gz 301444 BLAKE2B 2681f0290a4f8b335dcdf384a0c0692cf51e88ea829f80c8c857be328b00c618978a84957da4e23826e4597fe90764eb36ab9acbbc33f9a6ec8df3e3ff3f4d48 SHA512 b6ddb29c15b2d729605a6acb7c602f18c75a937cdfe9649d35d790a59fbb1d96a8d68975ba0a4c073c9f1750e383c67b7566dbcd81b3e8611501e9f4153e9a2b
DIST urllib3-2.0.0.tar.gz 276792 BLAKE2B 3f5966ea97f1ddbf73ef4d1d292b426f502a211fef6e2bc354a88dc95766faf99a5dd34cb891147c580a03b8c5fb2dd7fdee22988bd603db046c03245c850904 SHA512 24e1b34d266983cf4e1556cbe026cc62d7fdb14c5ec5dace800e0b40e0a4f898d4df1679de351d14598ab0f72eb1bec74b6d2976df628b786f4bab4cb4380044
DIST urllib3-2.0.1.tar.gz 277241 BLAKE2B ae4f323bcae505f2e177fd6c4764af78f5b98140366ac6e14f27eb0f5c55870f39bfdab6466628cd2fcf2171cd31ed6c82ae3f42e109834764aa87cfdd13f4ca SHA512 58b784052530f1447c8fca3db3309b127a7db352f8f6800765b92efb02762502ea9e6d50fee5d8c297a9ea0d6861c91f6db7254eb955941f0239d56f30d2dcc5
DIST urllib3-2.0.2.tar.gz 277703 BLAKE2B 1c7935a6aca8e60ad212eb35ef76009b75a8d080b1a572fe229e94a200e75c352ab41d831dde3d4a4643ecbbe54c2128f9d9ca1850d978fd1730d6d730ce3ab0 SHA512 874674342259f2f9b77b4aac90bd525ea50d4b6134008c22eb0fe7a04e688797564c3ec8e556600f75416df2983c972867e8a569d5d85a8dda748948217af38e
63 changes: 63 additions & 0 deletions dev-python/urllib3/urllib3-2.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
EAPI=8

DISTUTILS_USE_PEP517=hatchling
PYTHON_TESTED=( python3_{9..11} pypy3 )
PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
PYTHON_REQ_USE="ssl(+)"

inherit distutils-r1 pypi

DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
HOMEPAGE="
https://github.com/urllib3/urllib3/
https://pypi.org/project/urllib3/
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="brotli test zstd"
RESTRICT="!test? ( test )"

# [secure] extra is deprecated and slated for removal, we don't need it:
# https://github.com/urllib3/urllib3/issues/2680
RDEPEND="
>=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
<dev-python/PySocks-2.0[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
brotli? ( >=dev-python/brotlicffi-0.8.0[${PYTHON_USEDEP}] )
zstd? ( >=dev-python/zstandard-0.18.0[${PYTHON_USEDEP}] )
"
BDEPEND="
test? (
$(python_gen_cond_dep "
${RDEPEND}
dev-python/brotlicffi[\${PYTHON_USEDEP}]
dev-python/freezegun[\${PYTHON_USEDEP}]
dev-python/pytest[\${PYTHON_USEDEP}]
>=dev-python/tornado-4.2.1[\${PYTHON_USEDEP}]
>=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
>=dev-python/zstandard-0.18.0[\${PYTHON_USEDEP}]
" "${PYTHON_TESTED[@]}")
)
"

python_test() {
local -x CI=1
if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
einfo "Skipping tests on ${EPYTHON}"
return
fi

local EPYTEST_DESELECT=(
# take forever
test/contrib/test_pyopenssl.py::TestSocketSSL::test_requesting_large_resources_via_ssl
test/with_dummyserver/test_socketlevel.py::TestSSL::test_requesting_large_resources_via_ssl
)

epytest
}

0 comments on commit 6631faf

Please sign in to comment.