Skip to content

Commit

Permalink
dev-lang/execline: 2.3.0.4 version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
smaeul authored and williamh committed Jan 10, 2018
1 parent 7397fd7 commit 663dfff
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/execline/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST execline-2.3.0.0.tar.gz 81704 BLAKE2B 90f6f7656ce4ada831796995b7f046291c94d
DIST execline-2.3.0.1.tar.gz 82620 BLAKE2B 1e7715b7da6a5a1abded5e9e4a8edf0adab48f54a0153a1e23d96194379f8d64bc4399e169857d1e0e425da095acb8dc3c4b662785038376aec7a77f9ce1a955 SHA512 be72bff29055655275e2da0ed831034158300ff39184822966e35ff9a6c2dea4f7e5fc5e79bda40be91a791cb99ee9accc7cbdeccef3c4489bf2253e0a107365
DIST execline-2.3.0.2.tar.gz 82378 BLAKE2B bb1dc827054e9dd285ab737a8ae0d494c02e287ac64e755bb8584a3705992af98909f6e23d77313bdc37e4b543b25acd383d7e7053c6400bba3d448ced50a057 SHA512 0ec20bd0695bbf1aef9db6725c7d58ca95044401412ba85a22274d21aa37a5f51455739d403f929870dfcd4b59dcea474e0290a42e6a7dfe4136ef066b36e208
DIST execline-2.3.0.3.tar.gz 82476 BLAKE2B e54bf40037d988848a31b90ca477fb1a297bfc91a6ceb51289944cccc7af36a26b8323c63e8178bd9a252b482a703329c04c9f08a25c2cfe94f5baf60983d04c SHA512 2858ce62853f00f59e0cea8b886cd042f7ad04c6a86208266654d3d2e820b5d440e41cc4efb96fccdcc653d19957d343115a8e8c394b68f23addf941294fb172
DIST execline-2.3.0.4.tar.gz 82774 BLAKE2B a658b538d0a17f15876fe9a822bb7c7e4edba48d2fce1d3c0fe0fd06fd8a414e062a962ca3935992903a4abccf920bf6ee957743609905a6ce498e6fd3deded8 SHA512 ce73b69394ec061ad85cf6f69211180bffe69f1b9716217dadca5894a261f77343d54d5f0339b3822c472720e60c4aa100a0e05dc83f2ad6b926bb53b5141c15
55 changes: 55 additions & 0 deletions dev-lang/execline/execline-2.3.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit versionator

DESCRIPTION="a non-interactive scripting language"
HOMEPAGE="https://www.skarnet.org/software/execline/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"

LICENSE="ISC"
SLOT="0/$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="static static-libs"

DEPEND=">=sys-devel/make-3.81
static? (
>=dev-libs/skalibs-2.6.2.0[static-libs]
)
!static? (
>=dev-libs/skalibs-2.6.2.0
)
"
RDEPEND="
!static? (
>=dev-libs/skalibs-2.6.2.0:=
)
"

HTML_DOCS="doc/*"

src_prepare() {
default

# Remove QA warning about LDFLAGS addition
sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die

# configure overrides gentoo's -fstack-protector default
sed -i "/^tryflag CFLAGS -fno-stack-protector$/d" "${S}/configure" || die
}

src_configure() {
econf \
--bindir=/bin \
--dynlibdir=/$(get_libdir) \
--libdir=/usr/$(get_libdir)/${PN} \
--with-dynlib=/$(get_libdir) \
--with-lib=/usr/$(get_libdir)/skalibs \
--with-sysdeps=/usr/$(get_libdir)/skalibs \
$(use_enable !static shared) \
$(use_enable static allstatic) \
$(use_enable static static-libc) \
$(use_enable static-libs static)
}

0 comments on commit 663dfff

Please sign in to comment.