Skip to content

Commit

Permalink
dev-cpp/kokkos: add 3.7.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Jan 23, 2023
1 parent 2fee7f0 commit 667ed87
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/kokkos/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST kokkos-3.1.01.tar.gz 1972707 BLAKE2B fe31556ecba6b01ed6e480f0cb4ca4d7dc487d6b2a7e52df94d0e93b864ed5269a752f4fcdbacb55383e9dee3b72236f121b67d2f5eed10f3351219b063e7099 SHA512 4fa428ec33ec207147b3fcc5e0d297bcff4ed772ba6baa24ccaf56b691b72b70c69bd48fdf134f4e78234bf755377fe01a31611a41539c2d211ba9caed24b1f2
DIST kokkos-3.7.0.tar.gz 2301343 BLAKE2B b63ffc7c70141396986414375143d4df62a4bfffec0f0a346a278819557b42a025cd7f2a0825cd4d2d7c94a5c7c374b58be79dae9c45e012574b4c87c2ae0371 SHA512 f72b43096126cba11129ab44c2ebaeb1ee92b14db45bd451e86f40746e8edbfbe3415dee089080a6664ae4985e5796717c64bb5c508ca5e287b31bac248802f6
DIST kokkos-3.7.1.tar.gz 2305103 BLAKE2B c94493077190c1e5d2681d0e138012fcd82f91a1f7616ea7373f3c12f577a195937d507dd2d64f82902fa6760f63da8b3e2c1ef31a7114b9da21841280e22e33 SHA512 97cb7e05aec145ba9adae30b20ae3138a532db3a56cdd5e092d8f9c1e1788efe7a6f721282e2a5c5bf9c0da4c53d28f30b27fcb546b68aa8eaa589a362eb40c1
56 changes: 56 additions & 0 deletions dev-cpp/kokkos/kokkos-3.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake toolchain-funcs

DESCRIPTION="C++ Performance Portability Programming EcoSystem"
HOMEPAGE="https://github.com/kokkos"
MY_PV="$(ver_cut 1-2).0$(ver_cut 3)"
SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 -x86"
IUSE="+openmp test"
RESTRICT="!test? ( test )"

DEPEND="sys-apps/hwloc:="
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN}-${MY_PV}"

pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_INCLUDEDIR=include/kokkos
-DKokkos_ENABLE_TESTS=$(usex test)
-DKokkos_ENABLE_AGGRESSIVE_VECTORIZATION=ON
-DKokkos_ENABLE_SERIAL=ON
-DKokkos_ENABLE_HWLOC=ON
-DKokkos_HWLOC_DIR="${EPREFIX}/usr"
-DKokkos_ENABLE_OPENMP=$(usex openmp)
-DBUILD_SHARED_LIBS=ON
)

cmake_src_configure
}

src_test() {
local myctestargs=(
# Contains "death tests" which are known/expected(?) to fail
# https://github.com/kokkos/kokkos/issues/3033
# bug #791514
-E "(KokkosCore_UnitTest_OpenMP|KokkosCore_UnitTest_Serial)"
)

cmake_src_test
}

0 comments on commit 667ed87

Please sign in to comment.