forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.1
- Loading branch information
Jeroen Roovers
committed
Oct 5, 2016
1 parent
b3ca34e
commit 669ba7e
Showing
2 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST debhelper_10.2.1.tar.xz 353420 SHA256 be9b0c8b4f97facf2c6b3aadf437f7f256d8cc9fadd7c6aa3a32132fb85ba833 SHA512 09673875c85fcc3b74e87328f2980fa02fff0929c80d89216d3b852dee16faae3dc3704276ef9974bc62a26902468e57b87a655fc174f3f5f235a09dd02bc60a WHIRLPOOL e96909228f8fde052893f50ff23bcfe880e71c8921f07002f0a1dd1563d103b3eddb6d08fbc125beed42be622fd77d7eb69f5d3da41797780cc0e2d849cbbedc | ||
DIST debhelper_10.tar.xz 353684 SHA256 60bb7244b5b50deedefbf46d3f9fbe9d859ff9bb744984fa68e2f878ec50e485 SHA512 20c66022dfcf81dd546bc7f13d3b8830de901ff48309a24abc759e30b39b0ddd49ce9a14fa126688dd7f8aec70a634788a10127339566eb66adb5ced39af7294 WHIRLPOOL 26413cc01b04e8fb131e0be3d04f8f489236ad0fdcdfce99b642da9c1d26c3733aa486d4b1bfd5a51211e812591835508301faf1e0d68f7c476a164da4e5573b | ||
DIST debhelper_9.20150101.tar.gz 545089 SHA256 fd8d81d71d1bb0ba4b58c517465551231dd60811b98c867e4344bc55ec6a45f2 SHA512 62c85f751627cf0bdac392c6e8c5298995030962b7753047414e740b3767d722c209329c9f0c3c07c94e82bbb7250c163ce49b681e268a0decdbd19b72ea132a WHIRLPOOL 31315544c3ee695a53ef2310ad69e59c68fb0b73399305b9fe57ceb7b01faab72995e01aed270300dd0fbaed2686a5b565a8a08cfc31c720c5baa2a6c475ac4e | ||
DIST debhelper_9.20160814.tar.xz 344328 SHA256 2834a7c1dbeafd9402ea68948c815dab19d903503c45fd70e676269fccd359c0 SHA512 63072ba35ec8c62ee4c4d44833712925264c808a91f1522ef6a73377f2da3d11b285a21ad39158fd44693c801916189261186c8c7b28096719328a81a0a65f62 WHIRLPOOL 334f0aa8075896ec13a061b9841adb5f2b7c5fa6996b507785f50389c86c48e3c89a84ff1049ae7d7cbe4876b649010f892f54f1074ecafd76061bf0588e65d6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,74 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit eutils toolchain-funcs | ||
|
||
DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules" | ||
HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html" | ||
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux" | ||
IUSE="test" | ||
DH_LINGUAS=( de es fr ) | ||
IUSE+=" ${DH_LINGUAS[@]/#/linguas_}" | ||
|
||
NLS_DEPEND=$( | ||
printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]} | ||
) | ||
|
||
RDEPEND=" | ||
>=dev-lang/perl-5.10:= | ||
>=app-arch/dpkg-1.17 | ||
dev-perl/TimeDate | ||
virtual/perl-Getopt-Long | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
${NLS_DEPEND} | ||
test? ( | ||
dev-perl/Test-Pod | ||
sys-apps/fakeroot | ||
) | ||
" | ||
|
||
S=${WORKDIR}/${PN} | ||
|
||
src_compile() { | ||
tc-export CC | ||
|
||
local LANGS="" USE_NLS=no lingua | ||
for lingua in ${DH_LINGUAS[@]}; do | ||
if use linguas_${lingua}; then | ||
LANGS+=" ${lingua}" | ||
USE_NLS=yes | ||
fi | ||
done | ||
|
||
emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install | ||
dodoc doc/* debian/changelog | ||
docinto examples | ||
dodoc examples/* | ||
local lingua | ||
for manfile in *.1 *.7 ; do | ||
for lingua in ${DH_LINGUAS[@]}; do | ||
case ${manfile} in | ||
*.${lingua}.?) | ||
use linguas_${lingua} \ | ||
&& cp ${manfile} "${T}"/${manfile/.${lingua}/} \ | ||
&& doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/} | ||
;; | ||
*) | ||
doman ${manfile} | ||
;; | ||
esac | ||
done | ||
done | ||
} |