Skip to content

Commit

Permalink
media-tv/kodi: Fix compilation error due to use of ancient _G_ types
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Nov 28, 2018
1 parent 6791155 commit 66a13dd
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
39 changes: 39 additions & 0 deletions media-tv/kodi/files/kodi-17.6-wrapper.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
From bbc7a53911f1ef8a4a24b76d88c5b0e5899e082f Mon Sep 17 00:00:00 2001
From: Michael Cronenworth <[email protected]>
Date: Fri, 16 Mar 2018 13:48:34 -0500
Subject: [PATCH] DllLoader: Update variable to use standard va_list type

The _G_ types were ancient, internal-only types defined in _G_config.h
and are now deprecated.

https://sourceware.org/ml/libc-announce/2018/msg00000.html
https://sourceware.org/git/?p=glibc.git;a=commit;h=48a8f8328122ab8d06b7333cb87be46feeaf7cca

Signed-off-by: Michael Cronenworth <[email protected]>
---
xbmc/cores/DllLoader/exports/wrapper.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/xbmc/cores/DllLoader/exports/wrapper.c b/xbmc/cores/DllLoader/exports/wrapper.c
index 1980bfe65cac..7c7d4ac6131d 100644
--- a/xbmc/cores/DllLoader/exports/wrapper.c
+++ b/xbmc/cores/DllLoader/exports/wrapper.c
@@ -45,9 +45,6 @@ typedef int64_t off64_t;
typedef off64_t __off64_t;
typedef fpos_t fpos64_t;
#define stat64 stat
-#if defined(TARGET_DARWIN) || defined(TARGET_ANDROID)
-#define _G_va_list va_list
-#endif
#endif

#ifdef TARGET_POSIX
@@ -485,7 +482,7 @@ int __wrap___printf_chk(int flag, const char *format, ...)
return res;
}

-int __wrap___vfprintf_chk(FILE* stream, int flag, const char *format, _G_va_list ap)
+int __wrap___vfprintf_chk(FILE* stream, int flag, const char *format, va_list ap)
{
return dll_vfprintf(stream, format, ap);
}
1 change: 1 addition & 0 deletions media-tv/kodi/kodi-17.6-r9.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -17,6 +17,7 @@ FFMPEG_KODI_VERSION="17.5"
CODENAME="Krypton"
PATCHES=(
"${FILESDIR}/${P}-nmblookup.patch"
"${FILESDIR}/${P}-wrapper.patch"
)
SRC_URI="https://github.com/xbmc/libdvdcss/archive/${LIBDVDCSS_COMMIT}.tar.gz -> libdvdcss-${LIBDVDCSS_COMMIT}.tar.gz
https://github.com/xbmc/libdvdread/archive/${LIBDVDREAD_COMMIT}.tar.gz -> libdvdread-${LIBDVDREAD_COMMIT}.tar.gz
Expand Down

0 comments on commit 66a13dd

Please sign in to comment.