Skip to content

Commit

Permalink
app-emulation/reg: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
mrueg committed May 31, 2018
1 parent aa5c851 commit 66d3235
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/reg/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST reg-0.13.0.tar.gz 14958008 BLAKE2B 7afdb3f00732ad3fe4e8581d0773ba3d8ed4e9d41704e5aec7e45f16e407d19cc30cf8d4461d32719200b0253d26b609ff641c760b220685edb98bfb49f9b6b6 SHA512 7b9c23de23b798e9da4902a00d965c62452997240f53980eda478c8fa59ade985ca2f25fbe902597bcb32440dfcd41bd72c4631b4f4be956a48b75875e134018
11 changes: 11 additions & 0 deletions app-emulation/reg/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Manuel Rüger</name>
</maintainer>
<upstream>
<remote-id type="github">genuinetools/reg</remote-id>
</upstream>
</pkgmetadata>
31 changes: 31 additions & 0 deletions app-emulation/reg/reg-0.13.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit golang-build golang-vcs-snapshot

EGO_PN="github.com/genuinetools/reg"
EGIT_COMMIT="v${PV}"
GIT_COMMIT="b2cdf0428ddc051f8a39143b63311b515e26d012"
ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Docker registry v2 command line client"
HOMEPAGE="https://github.com/genuinetools/reg"
SRC_URI="${ARCHIVE_URI}"
LICENSE="MIT"
SLOT="0"
IUSE="seccomp"

RESTRICT="test"

src_compile() {
pushd src/${EGO_PN} || die
GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
popd || die
}

src_install() {
dobin bin/*
dodoc src/${EGO_PN}/README.md
}

0 comments on commit 66d3235

Please sign in to comment.