forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/cloud-init: 21.2 bump with py39
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <[email protected]>
- Loading branch information
1 parent
a115a7e
commit 6705fbf
Showing
4 changed files
with
202 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST cloud-init-20.1.tar.gz 1088152 BLAKE2B 1c075676bcf7454965beafaaa38f3cdf08f321ddd0303b7f710c49d2a69e0fb2ec8a81870a632b7504c47af6436555c97ea9fa9c8416955de78f8f551b5509b7 SHA512 ad28e4a0290165308ef2cdb8a935778ad99039978a204bee1098460de006bc3f375a3b81d0d72971fc4f4195d5d2ade9c648fb19e6d6eba12decf750dc54b6eb | ||
DIST cloud-init-20.4.tar.gz 1228898 BLAKE2B c5697af31e7219a060a82732fbae2e89dd00786e5b0feb638f1f64f6ce861df041ef687a6095cc3bdb5478f4f4c1504286155808102aea9cae853caa97d4ba1b SHA512 da2fa4673b253468380c4472795fd449809c8ac84d8f13ec1472b9b7e7d54e187ae06e5a81a36774793b05f4e1212dca57bc19aa8955b4c7fa7183cb100bfbb9 | ||
DIST cloud-init-21.2.tar.gz 1278878 BLAKE2B 74e07649a24fc85df54aafcd72797a05f0bdbcceb90fe90c6af7024da09e876780b67bb1d7963cd164d03e3151715944b1f3fd5709d3557ac341a09061409fcc SHA512 8cc24945efc6f16b3c64411c5e7e5b83582d337f1c3f546163d52c14a6177ff752e91ba1fec04b7ade800f921c2b79c04d032df62c2b4171930ca1fb74c49a7d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,96 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_7 python3_8 python3_9 ) | ||
DISTUTILS_USE_SETUPTOOLS=rdepend | ||
|
||
inherit distutils-r1 | ||
|
||
if [[ ${PV} == *9999 ]];then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://git.launchpad.net/cloud-init" | ||
else | ||
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~x86" | ||
fi | ||
|
||
DESCRIPTION="Cloud instance initialisation magic" | ||
HOMEPAGE="https://launchpad.net/cloud-init" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
CDEPEND=" | ||
dev-python/jinja[${PYTHON_USEDEP}] | ||
dev-python/oauthlib[${PYTHON_USEDEP}] | ||
dev-python/pyserial[${PYTHON_USEDEP}] | ||
>=dev-python/configobj-5.0.2[${PYTHON_USEDEP}] | ||
dev-python/pyyaml[${PYTHON_USEDEP}] | ||
dev-python/requests[${PYTHON_USEDEP}] | ||
dev-python/jsonpatch[${PYTHON_USEDEP}] | ||
dev-python/jsonschema[${PYTHON_USEDEP}] | ||
dev-python/six[${PYTHON_USEDEP}] | ||
" | ||
DEPEND=" | ||
test? ( | ||
${CDEPEND} | ||
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
dev-python/unittest2[${PYTHON_USEDEP}] | ||
dev-python/coverage[${PYTHON_USEDEP}] | ||
dev-python/contextlib2[${PYTHON_USEDEP}] | ||
) | ||
" | ||
RDEPEND=" | ||
${CDEPEND} | ||
net-analyzer/macchanger | ||
sys-apps/iproute2 | ||
sys-fs/growpart | ||
virtual/logger | ||
" | ||
|
||
PATCHES=( | ||
# Fix Gentoo support | ||
# https://code.launchpad.net/~gilles-dartiguelongue/cloud-init/+git/cloud-init/+merge/358777 | ||
"${FILESDIR}/${PN}-18.4-fix-packages-module.patch" | ||
"${FILESDIR}/${PN}-21.2-gentoo-support-upstream-templates.patch" | ||
"${FILESDIR}"/18.4-fix-filename-for-storing-locale.patch | ||
"${FILESDIR}"/18.4-fix-update_package_sources-function.patch | ||
"${FILESDIR}"/18.4-add-support-for-package_upgrade.patch | ||
) | ||
|
||
python_prepare_all() { | ||
# Fix location of documentation installation | ||
sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die | ||
sed -i 's/version=get_version(),/version=9999,/g' setup.py || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
# Do not use Makefile target as it does not setup environment correclty | ||
esetup.py nosetests -v --where cloudinit --where tests/unittests || die | ||
} | ||
|
||
python_install() { | ||
distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo | ||
} | ||
|
||
python_install_all() { | ||
keepdir /etc/cloud | ||
|
||
distutils-r1_python_install_all | ||
|
||
# installs as non-executable | ||
chmod +x "${D}"/etc/init.d/* | ||
} | ||
|
||
pkg_postinst() { | ||
elog "cloud-init-local needs to be run in the boot runlevel because it" | ||
elog "modifies services in the default runlevel. When a runlevel is started" | ||
elog "it is cached, so modifications that happen to the current runlevel" | ||
elog "while you are in it are not acted upon." | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
101 changes: 101 additions & 0 deletions
101
app-emulation/cloud-init/files/cloud-init-21.2-gentoo-support-upstream-templates.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,101 @@ | ||
From 823454f1ea140ec47f5f9c5c3c5ad62eb458eb8a Mon Sep 17 00:00:00 2001 | ||
From: Gilles Dartiguelongue <[email protected]> | ||
Date: Wed, 24 Oct 2018 10:52:46 +0200 | ||
Subject: [PATCH 2/5] Add support for gentoo in cloud.cfg and templates | ||
|
||
--- | ||
config/cloud.cfg.tmpl | 8 ++++++-- | ||
templates/hosts.gentoo.tmpl | 24 ++++++++++++++++++++++++ | ||
tools/render-cloudcfg | 2 +- | ||
3 files changed, 31 insertions(+), 3 deletions(-) | ||
create mode 100644 templates/hosts.gentoo.tmpl | ||
|
||
diff --git a/config/cloud.cfg.tmpl b/config/cloud.cfg.tmpl | ||
index 1fef133a..3f5a41a2 100644 | ||
--- a/config/cloud.cfg.tmpl | ||
+++ b/config/cloud.cfg.tmpl | ||
@@ -134,7 +134,7 @@ cloud_final_modules: | ||
# (not accessible to handlers/transforms) | ||
system_info: | ||
# This will affect which distro class gets used | ||
-{% if variant in ["alpine", "amazon", "arch", "centos", "debian", | ||
- "fedora", "freebsd", "netbsd", "openbsd", "rhel", | ||
- "suse", "ubuntu"] %} | ||
+{% if variant in ["alpine", "amazon", "arch", "centos", "debian", | ||
+ "fedora", "freebsd", "gentoo", "netbsd", | ||
+ "openbsd", "rhel", "suse", "ubuntu"] %} | ||
distro: {{ variant }} | ||
{% else %} | ||
# Unknown/fallback distro. | ||
@@ -172,7 +172,7 @@ system_info: | ||
primary: http://ports.ubuntu.com/ubuntu-ports | ||
security: http://ports.ubuntu.com/ubuntu-ports | ||
ssh_svcname: ssh | ||
-{% elif variant in ["alpine", "amazon", "arch", "centos", "fedora", | ||
- "rhel", "suse"] %} | ||
+{% elif variant in ["alpine", "amazon", "arch", "centos", "fedora", | ||
+ "gentoo", "rhel", "suse"] %} | ||
# Default user name + that default users groups (if added/used) | ||
default_user: | ||
name: {{ variant }} | ||
@@ -180,6 +180,10 @@ system_info: | ||
{% endif %} | ||
{% if variant == "suse" %} | ||
groups: [cdrom, users] | ||
+{% elif variant == "gentoo" %} | ||
+ groups: [users, wheel] | ||
+ primary_group: users | ||
+ no_user_group: true | ||
{% elif variant == "arch" %} | ||
groups: [wheel, users] | ||
{% else %} | ||
diff --git a/templates/hosts.gentoo.tmpl b/templates/hosts.gentoo.tmpl | ||
new file mode 100644 | ||
index 00000000..cd045fa6 | ||
--- /dev/null | ||
+++ b/templates/hosts.gentoo.tmpl | ||
@@ -0,0 +1,24 @@ | ||
+## template:jinja | ||
+{# | ||
+This file /etc/cloud/templates/hosts.gentoo.tmpl is only utilized | ||
+if enabled in cloud-config. Specifically, in order to enable it | ||
+you need to add the following to config: | ||
+ manage_etc_hosts: True | ||
+-#} | ||
+# Your system has configured 'manage_etc_hosts' as True. | ||
+# As a result, if you wish for changes to this file to persist | ||
+# then you will need to either | ||
+# a.) make changes to the master file in /etc/cloud/templates/hosts.gentoo.tmpl | ||
+# b.) change or remove the value of 'manage_etc_hosts' in | ||
+# /etc/cloud/cloud.cfg or cloud-config from user-data | ||
+# | ||
+# The following lines are desirable for IPv4 capable hosts | ||
+127.0.0.1 {{fqdn}} {{hostname}} | ||
+127.0.0.1 localhost.localdomain localhost | ||
+127.0.0.1 localhost4.localdomain4 localhost4 | ||
+ | ||
+# The following lines are desirable for IPv6 capable hosts | ||
+::1 {{fqdn}} {{hostname}} | ||
+::1 localhost.localdomain localhost | ||
+::1 localhost6.localdomain6 localhost6 | ||
+ | ||
diff --git a/tools/render-cloudcfg b/tools/render-cloudcfg | ||
index 8b7cb875..d109044e 100755 | ||
--- a/tools/render-cloudcfg | ||
+++ b/tools/render-cloudcfg | ||
@@ -4,7 +4,7 @@ import argparse | ||
import os | ||
import sys | ||
|
||
-VARIANTS = ["alpine", "amazon", "arch", "centos", "debian", "fedora", | ||
- "freebsd", "netbsd", "openbsd", "rhel", "suse", "ubuntu", | ||
- "unknown"] | ||
+VARIANTS = ["alpine", "amazon", "arch", "centos", "debian", "fedora", | ||
+ "freebsd", "gentoo", "netbsd", "openbsd", "rhel", "suse", | ||
+ "ubuntu", "unknown"] | ||
|
||
if "avoid-pep8-E402-import-not-top-of-file": | ||
_tdir = os.path.abspath(os.path.join(os.path.dirname(__file__), "..")) | ||
-- | ||
2.19.1 | ||
|