Skip to content

Commit

Permalink
gnome-extra/gucharmap: Version bump to 14.0.3
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Mar 29, 2022
1 parent 0988b27 commit 671c542
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/gucharmap/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gucharmap-14.0.2.tar.gz 1925142 BLAKE2B 3936c187ecdc104534b80830f9089417e8c2166a8e8dbfc848788a58acd9d65889f1242ecd3a2d9a5f2e657dcc052dee22b3ed543d2113509905a472192b19eb SHA512 4cfcebca0cac5cef8e6601c077a49e12aa56e76fec131ccf5ca1fb11bf40e5df8b6ae5ec83c2b64764c9d223d52824d4007c114ee7d85b4246855b8fc15c6c2d
DIST gucharmap-14.0.3.tar.gz 1931686 BLAKE2B e72b46450ad97a49519014882cbfd5792a07daf782fdf0d80e4b9221537548a57d3b43dc2b421f3f72d3b0adfee6f11c53304b4468c78b766ffee9536efebba2 SHA512 cb43265a2b54231c15331c299ed10bba8bb83bdc1860ee50764bed8a40ce1421f49edfeb7fa5814c8aac6c23f80936a966346849db83ddf7f94a370adeffc6c8
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
74 changes: 74 additions & 0 deletions gnome-extra/gucharmap/gucharmap-14.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
VALA_MIN_API_VERSION="0.26"

inherit gnome2-utils meson python-any-r1 vala xdg

DESCRIPTION="Unicode character map viewer and library"
HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap https://gitlab.gnome.org/GNOME/gucharmap/"
SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="2.90"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"

UNICODE_VERSION="14.0"

IUSE="+introspection gtk-doc vala"
REQUIRED_USE="vala? ( introspection )"

RDEPEND="media-libs/freetype:2
>=dev-libs/glib-2.32:2
>=x11-libs/gtk+-3.22:3[introspection?]
>=dev-libs/libpcre2-10.21:=
=app-i18n/unicode-data-${UNICODE_VERSION}*
>=x11-libs/pango-1.42.4-r2[introspection?]
"
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
app-text/docbook-xml-dtd:4.1.2
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
gtk-doc? ( >=dev-util/gtk-doc-1 )
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
vala? ( $(vala_depend) )
"

PATCHES=(
"${FILESDIR}"/14.0.1-install-user-help.patch
"${FILESDIR}"/14.0.1-fix-file-conflicts.patch
)

src_prepare() {
use vala && vala_src_prepare
xdg_src_prepare
}

src_configure() {
local emesonargs=(
-Dcharmap=true
-Ddbg=false # in 14.0.1 all this does is pass -ggdb3
$(meson_use gtk-doc docs)
$(meson_use introspection gir)
-Dgtk3=true
-Ducd_path="${EPREFIX}/usr/share/unicode-data"
$(meson_use vala vapi)
)

meson_src_configure
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit 671c542

Please sign in to comment.