Skip to content

Commit

Permalink
dev-tex/dvi2gr: EAPI7, improve ebuild.
Browse files Browse the repository at this point in the history
  • Loading branch information
mm1ke authored and monsieurp committed Aug 20, 2018
1 parent e31d8d3 commit 6732140
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

DESCRIPTION="DVI to Grace translator"
HOMEPAGE="http://plasma-gate.weizmann.ac.il/Grace/"
SRC_URI="ftp://plasma-gate.weizmann.ac.il/pub/grace/src/devel/${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="examples"

DEPEND="media-libs/t1lib"
RDEPEND="${DEPEND}"

src_prepare() {
tc-export CC
default
# respect flags
sed -i \
-e '/^LDFLAGS/d' -e '/^CFLAGS/d' -e '/^CC/d' \
Makefile || die
sed -i -e 's/DVI2GR=\.\/dvi2gr/DVI2GR=$(which dvi2gr)/g' runtest.sh || die
}

src_install() {
dobin ${PN}
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins *.ti runtest.sh
fi

insinto /usr/share/${PN}
doins -r fonts
}

pkg_postinst() {
einfo "Don't forget install the TeX-Fonts in Grace"
einfo " /usr/share/${PN}/fonts/FontDataBase"
}

0 comments on commit 6732140

Please sign in to comment.