Skip to content

Commit

Permalink
dev-ruby/activesupport: add 5.2.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
graaff committed Aug 8, 2018
1 parent d765984 commit 6754208
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/activesupport/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST rails-5.1.4.tgz 6132874 BLAKE2B ec5642b860b7c18cea2c56aa5e2a652e28ab08d39c5
DIST rails-5.1.5.tgz 6142269 BLAKE2B e31b6fb39df4a5cbfa9acd31058b018f5eb8d45d0886d9cb1de5d7de9ed082b67f27d257ac8eeffb0a2663466bc958c72d63309f0a68989d189a11510e835e3e SHA512 8fde1b043976c6bd69235ccbfc1f4ab593fa0cb7ec0dc0cbafcbd2727dfd1b405cc6131e41cc40871bc893cc64f524a347dd91efd1816b724deb5ca1cf879c63
DIST rails-5.1.6.tgz 6142931 BLAKE2B 0c24677946c3421e73903214822a13cb26609a3c7e7826020b76a48809a8672c1dfb05d1bd362fab956a397636db5e691a91bdea64ee6073190e8663fb58a7df SHA512 1ad70fb57af753bb6aff27345021af97d177aed95e295273044d8ef5723aa6b64fc03104d2cbd1cc5337127f71b3eef9b19fa582f4d53cb746ed9b152a8392bb
DIST rails-5.2.0.tgz 9233349 BLAKE2B 8b237f7b039baed6d2a3f19d138f5985443d8543247b01ba316668052fede66820894e3f5ef76a953a4bdb54febecb6299692899556ea029ebfcbcebbaba9409 SHA512 0d7fdbc05a69f7a7b5ce612c0ec8e5dcd51ffb63891d97ca08036d07b3fb3267699dd4a209fd698e5eb2ca8f6c7f4539e86044c3bd15d0c614feda16892d3d85
DIST rails-5.2.1.tgz 8795554 BLAKE2B 712fba696aeb8600dcd3b031b84a7ec164aa4d8ec386576ff367d5d45b3effd48515c9b8ef36ea93642776220685a1d8eec6909f705e62a80a06cf151fc42b43 SHA512 4484981845f9bba8882db6b4d1e0c4600b54baeda5cf1825fda7cbbb04cfdcf35e4caa19355cb843d1b96fc67801f28902d79d763dae71446db515691a32742e
71 changes: 71 additions & 0 deletions dev-ruby/activesupport/activesupport-5.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby23 ruby24 ruby25"

RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"

RUBY_FAKEGEM_BINWRAP=""

inherit ruby-fakegem eapi7-ver

DESCRIPTION="Utility Classes and Extension to the Standard Library"
HOMEPAGE="https://github.com/rails/rails"
SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"

LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RUBY_S="rails-${PV}/${PN}"

ruby_add_rdepend "
>=dev-ruby/concurrent-ruby-1.0.2:1
|| ( dev-ruby/i18n:1 dev-ruby/i18n:0.9 dev-ruby/i18n:0.8 dev-ruby/i18n:0.7 )
>=dev-ruby/tzinfo-1.1:1
>=dev-ruby/minitest-5.1:5"

# memcache-client, nokogiri, and builder are not strictly
# needed, but there are tests using this code.
ruby_add_bdepend "test? (
>=dev-ruby/dalli-2.2.1
>=dev-ruby/nokogiri-1.4.5
>=dev-ruby/builder-3.1.0
>=dev-ruby/listen-3.0.5:3
dev-ruby/rack
dev-ruby/mocha
)"

all_ruby_prepare() {
# Set the secure permissions that tests expect.
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"

# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' \
-e 's/gemspec/gemspec path: "activesupport"/' \
-e '5igem "builder"; gem "rack"' ../Gemfile || die
rm ../Gemfile.lock || die

# Avoid test that depends on timezone
sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die

# Avoid tests that seem to trigger race conditions.
rm -f test/evented_file_update_checker_test.rb || die

# Avoid test that generates filename that is too long
sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die

# Avoid tests requiring a live redis running
rm -f test/cache/stores/redis_cache_store_test.rb || die
sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
}

0 comments on commit 6754208

Please sign in to comment.