Skip to content

Commit

Permalink
dev-python/pyasn1-modules: Add python3.5 support
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 11, 2015
1 parent 4fc9e60 commit 675996b
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 1 deletion.
2 changes: 1 addition & 1 deletion dev-python/pyasn1-modules/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
<?xml version='1.0' encoding='UTF-8'?>
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
Expand Down
38 changes: 38 additions & 0 deletions dev-python/pyasn1-modules/pyasn1-modules-0.0.8-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="pyasn1 modules"
HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1-modules"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"

python_test() {
echoit() { echo "$@"; "$@"; }
local exit_status=0 test
for test in test/*.sh; do
PATH="${S}/tools:${PATH}" \
echoit sh "${test}" || exit_status=1
done
return ${exit_status}
}

python_install_all() {
distutils-r1_python_install_all
insinto /usr/share/${P}
doins -r tools
}

0 comments on commit 675996b

Please sign in to comment.