Skip to content

Commit

Permalink
dev-python/pytest: Bump to version 3.0.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Lars Wendler committed Jan 30, 2017
1 parent 4138542 commit 6784eef
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pytest/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST pytest-3.0.2.tar.gz 727551 SHA256 64d8937626dd2a4bc15ef0edd307d26636a72a3f3
DIST pytest-3.0.3.tar.gz 731934 SHA256 f213500a356800a483e8a146ff971ae14a8df3f2c0ae4145181aad96996abee7 SHA512 ec0b4a5f0d6673a339c5a70b402c004c23db7001005454329eeaea15d890f53b8f2740f6c6254499d0f915b9058bfdfa535d9f22847bb382a060d65204fce4af WHIRLPOOL 1883909fa23832e674cf912b1d88957dd435143dc124df5454c08ad02c8077473168f749ea94539c2c4b5cf08648a0bce7e90937bbdacd4bb69a4ccf15ecff23
DIST pytest-3.0.4.tar.gz 733339 SHA256 879fee2c1fdbaacd1bf2c0047677c6dd4aee05b9c1e64330b34d130a584fa40d SHA512 f8ee3eb84b564419beb0bb78abbe0ffe44920b35c60021d2c77b2bc3a5ec13245768f848ccb2a1864d46fc343cdc4b2bc4a33d9459bf388f64ea2aea0d9c337d WHIRLPOOL e48fc51e1de0fe38eaebd21ea4249dd915ffbf190d1955bd9aa77976b9c692bd0a2541d8802e9e100603af647279740e6329491b0ce09ef898d102e78984b2bb
DIST pytest-3.0.5.tar.gz 740656 SHA256 4a003aa956f023ce91aa6e166b555e6f02a4b0aeb459ac61e14f64c0d39037fd SHA512 b01c6272703ec93b7e7eefa584688a3d00cd97ac9cf54bc9501b596d4c370f9f74e06ee2223829b60469ea1a32c3a3c30b29aeacfaab1f23404d5f8345544ca1 WHIRLPOOL 9b044222fc628dd138e9eaaf27a930b6389e74dff09ec25c07392c4d965c30890a79f5fb663db6de4f612dbabd6338049d2ed45679928835f8c7a278530d6c05
DIST pytest-3.0.6.tar.gz 748748 SHA256 643434a9f1a188271da35e20064cb8b6c5440976c5bb541dc7b5b0e3cf75d940 SHA512 0e983f1f52c18327537d20be30425f4c74037d1fbf6b4aedf2646cf21d450fa9b2b20625f26f5db759b4fe1fd28c6640cb1df88e667efaeea6642e7f02f01e06 WHIRLPOOL 708e5041135883ba31d9712880672f64bf05c0bf40a544061cb42fed4d2aec111bfdf82b63f10e8a87c2b76870e3ea364b396258f0674d2199e43fe93cf2922e
71 changes: 71 additions & 0 deletions dev-python/pytest/pytest-3.0.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )

inherit distutils-r1

DESCRIPTION="Simple powerful testing with Python"
HOMEPAGE="http://pytest.org/ https://pypi.python.org/pypi/pytest"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="doc test"

# When bumping, please check setup.py for the proper py version
PY_VER="1.4.29"
COMMON_DEPEND="
>=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
doc? (
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
"
DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/hypothesis-3.5.2[${PYTHON_USEDEP}]
>dev-python/pytest-xdist-1.13[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
"
RDEPEND="${COMMON_DEPEND}
!dev-python/logilab-common
"

python_prepare_all() {
chmod o-w *egg*/* || die
# Disable versioning of py.test script to avoid collision with
# versioning performed by the eclass.
sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"

distutils-r1_python_prepare_all
}

python_test() {
# test_nose.py not written to suit py3.2 in pypy3
if [[ "${EPYTHON}" == pypy3 ]]; then
"${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -x -v \
--ignore=testing/BUILD_nose.py \
|| die "tests failed with ${EPYTHON}"
else
"${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -v testing || die "tests failed with ${EPYTHON}"
fi
}

python_compile_all(){
use doc && emake -C doc/en html
}

python_install_all() {
use doc && HTML_DOCS=( doc/en/_build/html/. )
distutils-r1_python_install_all
}

0 comments on commit 6784eef

Please sign in to comment.