Skip to content

Commit

Permalink
net-misc/ena-driver: add 2.13.0
Browse files Browse the repository at this point in the history
Signed-off-by: Eray Aslan <[email protected]>
  • Loading branch information
erayaslan committed Sep 10, 2024
1 parent 5d3f5cf commit 67b1d0a
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/ena-driver/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ena-driver-2.11.1-linux.tar.gz 1441591 BLAKE2B 39db9d21efd0d7f810304a1be0be13dd0c944419a9e5aee5a60c3dee310f990af9787cb297e36e718aa3f62ff3a7e9ce4e8302a19efcc3b151438869827b540d SHA512 f27c556a902ee276022ddafec7cda70790280587f470968f233e3de09a7dac3b49f43a2b7dba1018489c9ff5f0f554201fe63b82533c6a627b7f533c2b4910c5
DIST ena-driver-2.12.2-linux.tar.gz 1444018 BLAKE2B 54223073bb096e8b6d29dc7bc8c971f5b99dd8803d5ece5e631120a9b2b8d180742cb74d5986dc163e3de53f223161dedc61102def498ea6274f117ae9508055 SHA512 93cb93c78aa409a1f9c3d542e1271dda9630641ceb32ecd2f69b69b380cf9625e1bc89721726ffcd3f64ff538df87e276748c5c7ac1f625a171624ffff776b6a
DIST ena-driver-2.12.3-linux.tar.gz 1444176 BLAKE2B 8dedd042d912082d60c29aa121b09e9d18ae7294257e217ac17970ea34ef0b7871d4ab87995f5cf59512174288e35d2c6bdd6aab3cd04c972e077364f8a4e9da SHA512 e1afaa3826e0b89c0cd07293ee300f14e452018e06ea7ac2048e4015c1d7115d3f1f112bd3897c6cd177314d6ebb63fd3111d1b45c76f9bc818dcf30d3ecf1cc
DIST ena-driver-2.13.0-linux.tar.gz 1450959 BLAKE2B 3536d976505de48f64ad33bb30269dbc090631e862c68c250f9452e5537018f86ecb93fa2272a812172c9145d33ecef7e82a1cee3cf86db53f520f6e2b3d3545 SHA512 2be761afae1374ab5d8043d01d8521c21c944d8e6830b0cf24dea6e51a4b2e1751d5521ad261af9eebca819c9c15ebcec5a84b51af505df7bc9cd99ef0350939
30 changes: 30 additions & 0 deletions net-misc/ena-driver/ena-driver-2.13.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit linux-mod-r1

DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64"

BDEPEND="app-arch/unzip"

CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
DOCS=(
README.rst
RELEASENOTES.md
ENA_Linux_Best_Practices.rst
)

src_compile() {
local modlist=( ena=net )
local modargs=( CONFIG_MODULE_SIG=n BUILD_KERNEL="${KV_FULL}" )
linux-mod-r1_src_compile
}

0 comments on commit 67b1d0a

Please sign in to comment.