Skip to content

Commit

Permalink
dev-ada/aunit: add 24.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jan 1, 2024
1 parent e2293e5 commit 67c60aa
Show file tree
Hide file tree
Showing 3 changed files with 40 additions and 2 deletions.
1 change: 1 addition & 0 deletions dev-ada/aunit/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST aunit-23.0.0.tar.gz 131699 BLAKE2B 04ff77214ab6f4f5d59ea0609fffbc6fcfb4695d2fbbed45efa14e2b745c33868e1c134e5d00a7c3d8f11b1a8d15c6212110c78a53df4230b5862fb9b912a434 SHA512 450caa79e4808188107cd065665ca9cab599934e3934d18406b08d3ccebe26c1e95cd0c712ea3403d6082c7c5e8fd9ecf09ae3b63d231b80ad575048b3d61943
DIST aunit-24.0.0.tar.gz 131699 BLAKE2B e43e7a94b278597475767d93f28a95a586abeaf45d141ea7035df9cb45d1be67c189a5be3d0364943b4649270f8f96d7cfd20fcba7a28917b14266c9e9424815 SHA512 25b973d1eb35e9e15ed24abe9c4ad7165d684c0e72abe619dcb9bec04cef8b28c78c1994e96e4bc29fd3b06567e15360f47ac87f49e1fa9888f55675defc226f
3 changes: 1 addition & 2 deletions dev-ada/aunit/aunit-23.0.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -14,7 +14,6 @@ SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""

RDEPEND="${ADA_DEPS}"
DEPEND="${RDEPEND}
Expand Down
38 changes: 38 additions & 0 deletions dev-ada/aunit/aunit-24.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
inherit ada multiprocessing

DESCRIPTION="Ada unit testing framework"
HOMEPAGE="http://libre.adacore.com/tools/aunit/"
SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="${ADA_DEPS}"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"

REQUIRED_USE="${ADA_REQUIRED_USE}"

src_compile() {
emake GPROPTS_EXTRA="-j$(makeopts_jobs) -v -cargs ${ADAFLAGS}"
}

src_install() {
emake INSTALL="${D}"/usr install
einstalldocs
mv "${D}"/usr/share/examples/${PN} "${D}"/usr/share/doc/${PF}/examples || die
rmdir "${D}"/usr/share/examples || die
rm -r "${D}"/usr/share/gpr/manifests || die
}

src_test() {
emake PROJECT_PATH_ARG="ADA_PROJECT_PATH=$(pwd)/lib/gnat" -C test
}

0 comments on commit 67c60aa

Please sign in to comment.