Skip to content

Commit

Permalink
games-engines/gemrb: [QA] Remove WANT_CMAKE
Browse files Browse the repository at this point in the history
* Other misc python fixes
Bug: https://bugs.gentoo.org/show_bug.cgi?id=616064
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: gentoo#4528
  • Loading branch information
SoapGentoo committed May 1, 2017
1 parent fcc333a commit 6855ac7
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 31 deletions.
52 changes: 24 additions & 28 deletions games-engines/gemrb/gemrb-0.8.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,11 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 )
WANT_CMAKE=always
inherit eutils python-any-r1 cmake-utils gnome2-utils

inherit eutils gnome2-utils python-single-r1 cmake-utils

DESCRIPTION="Reimplementation of the Infinity engine"
HOMEPAGE="http://gemrb.sourceforge.net/"
Expand All @@ -14,9 +15,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="media-libs/freetype
media-libs/libpng:0
RDEPEND="
media-libs/freetype
media-libs/libpng:0=
>=media-libs/libsdl-1.2[video]
media-libs/libvorbis
media-libs/openal
Expand All @@ -26,41 +29,34 @@ RDEPEND="media-libs/freetype
DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_setup() {
python-any-r1_pkg_setup
}

src_prepare() {
default
cmake-utils_src_prepare

sed -i \
-e '/COPYING/d' \
CMakeLists.txt || die
}

src_configure() {
mycmakeargs=(
-DBIN_DIR="/usr/bin"
-DCMAKE_INSTALL_PREFIX="/usr"
-DDATA_DIR="/usr/share/gemrb"
-DDOC_DIR="/usr/share/doc/${PF}"
-DICON_DIR=/usr/share/pixmaps
-DLIB_DIR="/usr/$(get_libdir)"
-DMAN_DIR=/usr/share/man/man6
-DMENU_DIR=/usr/share/applications
-DSVG_DIR=/usr/share/icons/hicolor/scalable/apps
-DSYSCONF_DIR="/etc/${PN}"
)
local mycmakeargs=(
-DBIN_DIR=bin
-DDATA_DIR=share/gemrb
-DDOC_DIR=share/doc/${PF}
-DICON_DIR=share/pixmaps
-DLIB_DIR=$(get_libdir)
-DMAN_DIR=share/man/man6
-DMENU_DIR=share/applications
-DSVG_DIR=share/icons/hicolor/scalable/apps
-DSYSCONF_DIR=/etc/${PN}
# needed, causes massive QA warnings otherwise
-DCMAKE_SKIP_RPATH=ON
)
cmake-utils_src_configure
}

src_compile() {
cmake-utils_src_compile
}

src_install() {
DOCS="README NEWS AUTHORS" \
cmake-utils_src_install
cmake-utils_src_install
python_fix_shebang "${ED%/}"/usr/bin/extend2da.py
}

pkg_preinst() {
Expand Down
7 changes: 4 additions & 3 deletions games-engines/gemrb/gemrb-0.8.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python2_7 )
WANT_CMAKE=always

inherit eutils python-any-r1 cmake-utils gnome2-utils games

DESCRIPTION="Reimplementation of the Infinity engine"
Expand Down Expand Up @@ -38,7 +39,7 @@ src_prepare() {
}

src_configure() {
mycmakeargs=(
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
-DBIN_DIR="${GAMES_BINDIR}"
-DDATA_DIR="${GAMES_DATADIR}/gemrb"
Expand Down

0 comments on commit 6855ac7

Please sign in to comment.