Skip to content

Commit

Permalink
dev-db/freetds: new version 1.00.13.
Browse files Browse the repository at this point in the history
This new version fixes some bugs and adds a few new features. At some
point, the upstream project added support for compiling with
-Werror=format-security, so that takes care of our bug 521270.

The ebuild now has support for GnuTLS, OpenSSL/LibreSSL (bug 490554),
and iconv. These were all present upstream, but missing from the
ebuild until now. It also adds a runtime dependency on bind-tools,
which is used by the "osql" script (bug 487176).

Gentoo-Bug: 487176
Gentoo-Bug: 490554
Gentoo-Bug: 521270

Package-Manager: portage-2.2.28
  • Loading branch information
orlitzky committed Jul 31, 2016
1 parent 3ca664f commit 687155c
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/freetds/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST freetds-0.91.tar.gz 2136329 SHA256 6a8148bd803aebceac6862b0dead1c5d9659f7e1038993abfe0ce8febb322465 SHA512 4dadafe49848ab5505b0fa5bd650e19e7652c3e1181d3c49f087c50ed055f395eaf5917a99744ed3594e4af9032c4e18f397af58fb1010e695ac2c0bc601b5e3 WHIRLPOOL 63662b56011edb6d22ce28cc7bad3af272ff81862f0d8ff65b113af260e3c8d05a9d941c1cf4b8039b99f460c3a5c8364dd69d42d8e98c0c92530462f732dec2
DIST freetds-1.00.1.tar.gz 4649187 SHA256 a00048d5b1b568b62a7d1dd0e517e064273c9c7d807ca4a986f4e5ef0fc65e6c SHA512 dab5139ddc6e3c7a2c61f76dd833d7ff499c9b63329eb9712bb94e47700991ecd05e86aaa0900682dd7626660b13c124ecbf23c1dcc40f5ca855b3fb00a54d45 WHIRLPOOL 33096719913b81d90462b5392041117996ae942815e69b793723a5c90d17c2f1ebb16db193d93363c2d98525698c6ec741cc62b6430613163ad89da795defd79
DIST freetds-1.00.13.tar.gz 4639311 SHA256 ebb6dfc0ce34432e3712fbc638f18bc98f4af0c6f327fd2a0edd8ee16f00c15f SHA512 202d5a9477b1e924317b04a54d3186c333ef8f9d5054c3346635a2a3af268938a5bbf58fe8500ef6c21801046d9024d57404e99f9a8e2b0e639fcea39aecaa69 WHIRLPOOL 6a3be06872cb57e51c5c3181e1b141c659be6a290b5ec312e656e05998c2bae1f7ebf353c02dbd8c1b665ab6722fbb2c4122c3eabedc8bc1b7916fb61b5f4486
DIST freetds-1.00.tar.gz 4648806 SHA256 604ff9fe95bf5e2e650f8648b19ae488959269a4274e95dc17e3b66f29779a9b SHA512 713aec9ac7952aa70a3e7f5fe3ab2d9be7b19511f1d58cf3397e80f99f155835508d9a7bf8dad37f64f07bc1c78258df3f17f3049f89e32cd2d654fd3b689bb4 WHIRLPOOL bf94e4b71602e779638df481a706bad147eb5c9596d8993b1409e1026a79e82162b5afdde923bdcb2b9bee498ade1b474fa7f99deb74652faf81b9c2dbed23a3
73 changes: 73 additions & 0 deletions dev-db/freetds/freetds-1.00.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools

DESCRIPTION="Tabular Datastream Library"
HOMEPAGE="http://www.freetds.org/"
SRC_URI="ftp://ftp.freetds.org/pub/freetds/stable/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
IUSE="gnutls iconv kerberos libressl mssql iodbc odbc ssl"
RESTRICT="test"

DEPEND="
gnutls? ( net-libs/gnutls )
iconv? ( virtual/libiconv )
iodbc? ( dev-db/libiodbc )
kerberos? ( virtual/krb5 )
odbc? ( dev-db/unixODBC )
ssl? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
)"

# bind-tools is needed because the osql script calls "host".
RDEPEND="${DEPEND}
net-dns/bind-tools
sys-apps/grep
sys-apps/sed
virtual/awk"

src_prepare() {
default
# Fix the iodbc include path in the configure script. Otherwise, it
# can't find isql.h.
sed -ie 's:with_iodbc/include":with_iodbc/include/iodbc":' \
configure.ac \
|| die "failed to fix the iodbc include path in configure.ac"
eautoreconf
}

src_configure() {
local myconf=( --with-tdsver=7.4 )

# The configure script doesn't support --without-{i,unix}odbc and
# it will still search for the associated headers if you try that
# Instead, to disable {i,unix}odbc, you just have to omit the
# --with-{i,unix}odbc line.
if use iodbc ; then
myconf+=( --enable-odbc --with-iodbc="${EPREFIX}/usr" )
fi

if use odbc ; then
myconf+=( --enable-odbc --with-unixodbc="${EPREFIX}/usr" )
fi

myconf+=( $(use_enable iconv libiconv) )
use iconv && myconf+=( --with-libiconv-prefix="${EPREFIX}/usr" )
myconf+=( $(use_enable kerberos krb5) )
myconf+=( $(use_enable mssql msdblib) )
myconf+=( $(use_with gnutls) )
myconf+=( $(use_with ssl openssl "${EPREFIX}/usr") )

# The docdir doesn't contain ${PV} without this
myconf+=( --docdir="/usr/share/doc/${PF}" )

econf "${myconf[@]}"
}

0 comments on commit 687155c

Please sign in to comment.