forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-misc/owncloud-client: 2.7.4.2934 bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <[email protected]>
- Loading branch information
Showing
2 changed files
with
85 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST ownCloud-2.7.4.2934.tar.xz 14151708 BLAKE2B ad6f3d827a2fdcead6fdc2514696e8fbdb75b2d365c9a09602b95b24c669695e3693167f5da305e27e6fb2266f106b50c578def1d1518730926a10f640defbd9 SHA512 7e04d987751d0b8e29fbe8ba8ae58f38fabd7f5007f7508d001532e595b00f58cce487b1d180928154286ffd6b01db1e6ca0407f7d675e8b101ec4ae8414f2a6 | ||
DIST owncloudclient-2.6.3.14058.tar.xz 21246672 BLAKE2B 15b75c2162d22c22827a057242d783e739837f618c2f65be3edce6b2678aaa13505fd14c4e4088374c240537a999d9aff7758ccb93993e0cbdebb886f735311c SHA512 e2159dc5668f263449e7a9a20ef10c6bb140ea5bd1128a6d3438abce03bc4913bb4eecbacc5160c8018398b6fa75ccfb2a9ab9ad637965e41caebc83994b80b3 |
84 changes: 84 additions & 0 deletions
84
net-misc/owncloud-client/owncloud-client-2.7.4.2934.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,84 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake xdg | ||
|
||
MY_PN="ownCloud" | ||
DESCRIPTION="Synchronize files from ownCloud Server with your computer" | ||
HOMEPAGE="https://owncloud.org/" | ||
SRC_URI="https://download.owncloud.com/desktop/${MY_PN}/stable/${PV}/source/${MY_PN}-${PV}.tar.xz" | ||
|
||
LICENSE="CC-BY-3.0 GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc dolphin gnome-keyring nautilus test" | ||
|
||
COMMON_DEPEND=">=dev-db/sqlite-3.4:3 | ||
dev-libs/qtkeychain[gnome-keyring?,qt5(+)] | ||
dev-qt/qtconcurrent:5 | ||
dev-qt/qtcore:5 | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtnetwork:5[ssl] | ||
dev-qt/qtsql:5 | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtxml:5 | ||
sys-fs/inotify-tools | ||
dolphin? ( | ||
kde-frameworks/kcoreaddons:5 | ||
kde-frameworks/kio:5 | ||
) | ||
nautilus? ( dev-python/nautilus-python )" | ||
|
||
RDEPEND="${COMMON_DEPEND}" | ||
DEPEND="${COMMON_DEPEND} | ||
dev-qt/linguist-tools:5 | ||
kde-frameworks/extra-cmake-modules | ||
doc? ( | ||
dev-python/sphinx | ||
dev-tex/latexmk | ||
dev-texlive/texlive-latexextra | ||
virtual/latex-base | ||
) | ||
test? ( | ||
dev-util/cmocka | ||
dev-qt/qttest:5 | ||
)" | ||
|
||
RESTRICT="!test? ( test )" | ||
|
||
S=${WORKDIR}/${MY_PN}-${PV} | ||
|
||
src_prepare() { | ||
# Keep tests in ${T} | ||
sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die | ||
|
||
if ! use nautilus; then | ||
pushd shell_integration > /dev/null || die | ||
cmake_comment_add_subdirectory nautilus | ||
popd > /dev/null || die | ||
fi | ||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc | ||
-DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF} | ||
-DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc) | ||
-DBUILD_SHELL_INTEGRATION_DOLPHIN=$(usex dolphin) | ||
-DBUILD_TESTING=$(usex test) | ||
) | ||
|
||
cmake_src_configure | ||
} | ||
|
||
pkg_postinst() { | ||
if ! use doc ; then | ||
elog "Documentation and man pages not installed" | ||
elog "Enable doc USE-flag to generate them" | ||
fi | ||
xdg_pkg_postinst | ||
} |