Skip to content

Commit

Permalink
gnome-extra/evolution-data-server: bump to 3.22.4 and fix IMAP NOTIFY…
Browse files Browse the repository at this point in the history
… extension

The gperf-3.1 patch doesn't seem to be needed, as it works with gperf-3.1
without it, but include it just in case (gperf-3.0.4 generated version looks to
be included in the tarball, and so used instead unless we regenerate).

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
leio committed Feb 6, 2017
1 parent e9081ed commit 68749a1
Show file tree
Hide file tree
Showing 4 changed files with 186 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-extra/evolution-data-server/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST evolution-data-server-3.20.5.tar.xz 5067732 SHA256 0d1586cd326d997497a2a6fddd939a83892be07cb20f8c88fda5013f8c5bbe7e SHA512 8376331ae0ee96013d5c61b1da92393486d0eb9e0fed63199d4b6c28d92cb6d9dc45826fd65b476d894141d507742e8574168bc99b8704bebe8b39bbd297606e WHIRLPOOL 3c3417603bd2a18c7a3370e32af7f1581fc399ebe6f721d0ac678a5978d667b58df2927eb02f240b4c2f139133e06f25e13a47879b7b7a470cd1283a186bba10
DIST evolution-data-server-3.20.6.tar.xz 5069584 SHA256 c9280149477cc0c75c20214814cfc54f0e5827c40080dadbbe4b4188479913aa SHA512 0526e64c407bd569b8fb45faeb902cdc15e46e5020c4187d76102f8e0b3173fdd0a742383cfed8de0351dd719c2ad33b39c7d4cd656312d07526ae8b85198dbc WHIRLPOOL e229d245ae79c6ecc2910bc6f110314e568d6afc546157af4e2a98be85e67ac1615f4085f3a4df2a94e658881ef6aa1c6d336b4ae3211bd0a85b2a81eef64f91
DIST evolution-data-server-3.22.3.tar.xz 5558616 SHA256 0c58dfc2bdd72ea5bef65e2ef9f2969c8ceef253d3e3150a894647a00d69cf4f SHA512 17a8cb07cc516925a8cc27798d61935ddd0de2074f7a245283aec8932cd1f023c2c0cd5339b5896984656a560865017ea9df9d77e80deb7fc1f432a82f5ba935 WHIRLPOOL f0ccfcf0080b785c5d35fd2afe072922c9538a10a60666459171e2b9d79e42ee30be2dd766abe1ffdca026a1f9f43b1764b60fc3dc1d5453bc3f55ce863ed36b
DIST evolution-data-server-3.22.4.tar.xz 5559372 SHA256 0c9c64f209bfd50dbace342ab3b673bcea74ad5fe01a7bc87c1a98d997349cb8 SHA512 38773c4ac65e69b02fd6d5abb0db843f038c383391e1c1006e54bda518f89741b6637f480d70e3cd79b31a812190d55ceec5c8b187d62d9ce582b0d6c362850c WHIRLPOOL d7808803328fcdcaab60934f7b674c599c04242bf6edd751cdc32de99b672a5f6d91b0f48bd42596c66400c09a73e26340b443216118667bfa58ca0fd5cb7cb8
134 changes: 134 additions & 0 deletions gnome-extra/evolution-data-server/evolution-data-server-3.22.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
VALA_USE_DEPEND="vapigen"

inherit db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx

DESCRIPTION="Evolution groupware backend"
HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"

# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
SLOT="0/59" # subslot = libcamel-1.2 soname version

IUSE="api-doc-extras berkdb +gnome-online-accounts +gtk google +introspection ipv6 ldap kerberos vala +weather"
REQUIRED_USE="vala? ( introspection )"

KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"

# sys-libs/db is only required for migrating from <3.13 versions
# gdata-0.15.1 is required for google tasks
# berkdb needed only for migrating old calendar data, bug #519512
RDEPEND="
>=app-crypt/gcr-3.4
>=app-crypt/libsecret-0.5[crypt]
>=dev-db/sqlite-3.7.17:=
>=dev-libs/glib-2.46:2
>=dev-libs/libgdata-0.10:=
>=dev-libs/libical-0.43:=
>=dev-libs/libxml2-2
>=dev-libs/nspr-4.4:=
>=dev-libs/nss-3.9:=
>=net-libs/libsoup-2.42:2.4
dev-libs/icu:=
sys-libs/zlib:=
virtual/libiconv
berkdb? ( >=sys-libs/db-4:= )
gtk? (
>=app-crypt/gcr-3.4[gtk]
>=x11-libs/gtk+-3.10:3
)
google? (
>=dev-libs/json-glib-1.0.4
>=dev-libs/libgdata-0.15.1:=
>=net-libs/webkit-gtk-2.11.91:4
)
gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
kerberos? ( virtual/krb5:= )
ldap? ( >=net-nds/openldap-2:= )
weather? ( >=dev-libs/libgweather-3.10:2= )
"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
dev-util/gdbus-codegen
dev-util/gperf
>=dev-util/gtk-doc-am-1.14
>=dev-util/intltool-0.35.5
>=gnome-base/gnome-common-2
>=sys-devel/gettext-0.17
virtual/pkgconfig
vala? ( $(vala_depend) )
"

# Some tests fail due to missings locales.
# Also, dbus tests are flacky, bugs #397975 #501834
# It looks like a nightmare to disable those for now.
RESTRICT="test"

# From gnome-3-22 branch, will be included in 3.22.5 release
PATCHES=(
"${FILESDIR}"/${PV}-gperf-3.1.patch
"${FILESDIR}"/${PV}-imap-notify.patch
)

pkg_setup() {
python-any-r1_pkg_setup
}

src_prepare() {
use vala && vala_src_prepare
gnome2_src_prepare
}

src_configure() {
# /usr/include/db.h is always db-1 on FreeBSD
# so include the right dir in CPPFLAGS
use berkdb && append-cppflags "-I$(db_includedir)"

# phonenumber does not exist in tree
gnome2_src_configure \
$(use_enable api-doc-extras gtk-doc) \
$(use_with api-doc-extras private-docs) \
$(usex berkdb --with-libdb="${EPREFIX}"/usr --with-libdb=no) \
$(use_enable gnome-online-accounts goa) \
$(use_enable gtk) \
$(use_enable google google-auth) \
$(use_enable google) \
$(use_enable introspection) \
$(use_enable ipv6) \
$(use_with kerberos krb5 "${EPREFIX}"/usr) \
$(use_with kerberos krb5-libs "${EPREFIX}"/usr/$(get_libdir)) \
$(use_with ldap openldap) \
$(use_enable vala vala-bindings) \
$(use_enable weather) \
--enable-largefile \
--enable-smime \
--with-systemduserunitdir="$(systemd_get_userunitdir)" \
--without-phonenumber \
--disable-examples \
--disable-uoa
}

src_test() {
unset ORBIT_SOCKETDIR
unset SESSION_MANAGER
virtx emake check
}

src_install() {
gnome2_src_install

if use ldap; then
insinto /etc/openldap/schema
doins "${FILESDIR}"/calentry.schema
dosym /usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
fi
}
24 changes: 24 additions & 0 deletions gnome-extra/evolution-data-server/files/3.22.4-gperf-3.1.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From 60d1cbbdc49ea254e30303d936e8f2b6b136afe4 Mon Sep 17 00:00:00 2001
From: Milan Crha <[email protected]>
Date: Mon, 6 Feb 2017 18:30:49 +0100
Subject: Bug 778222 - Fix a build break with gperf 3.1

---
camel/providers/imapx/camel-imapx-tokens.txt | 1 -
1 file changed, 1 deletion(-)

diff --git a/camel/providers/imapx/camel-imapx-tokens.txt b/camel/providers/imapx/camel-imapx-tokens.txt
index ed278bd..61c7115 100644
--- a/camel/providers/imapx/camel-imapx-tokens.txt
+++ b/camel/providers/imapx/camel-imapx-tokens.txt
@@ -1,7 +1,6 @@
/* This contains all of the keywords we care about. These
can be converted to an id very efficiently */
struct _imapx_keyword {const gchar *name; camel_imapx_id_t id; };
-struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register unsigned int len);
%%
ALERT, IMAPX_ALERT
ALREADYEXISTS, IMAPX_ALREADYEXISTS
--
cgit v0.12

27 changes: 27 additions & 0 deletions gnome-extra/evolution-data-server/files/3.22.4-imap-notify.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 5d830ed06a4bc4313a1f08b6fe47291d02639e04 Mon Sep 17 00:00:00 2001
From: Milan Crha <[email protected]>
Date: Mon, 6 Feb 2017 19:58:54 +0100
Subject: Bug 778069 - UI not updated after IMAP NOTIFY notifications

---
camel/providers/imapx/camel-imapx-server.c | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/camel/providers/imapx/camel-imapx-server.c b/camel/providers/imapx/camel-imapx-server.c
index 6b23a9a..09735fa 100644
--- a/camel/providers/imapx/camel-imapx-server.c
+++ b/camel/providers/imapx/camel-imapx-server.c
@@ -1685,6 +1685,10 @@ imapx_untagged_status (CamelIMAPXServer *is,
if (mailbox != NULL) {
camel_imapx_mailbox_handle_status_response (mailbox, response);
camel_imapx_store_emit_mailbox_updated (imapx_store, mailbox);
+
+ if (camel_imapx_server_is_in_idle (is))
+ g_signal_emit (is, signals[REFRESH_MAILBOX], 0, mailbox);
+
g_object_unref (mailbox);
}

--
cgit v0.12

0 comments on commit 68749a1

Please sign in to comment.