forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
123 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST mysql-connector-odbc-8.0.22-src.tar.gz 3726015 BLAKE2B 055920446767b0c9a30a0ca4773e71d662b398a9849df1a0b7975d71a21cfb23f540d8dda5430c717569f173e63673d3e51b025bb098e51202093d33e19bc142 SHA512 c613ae60346cea2e57bade89d813fd5ac21d0712d3d751e3acbc275421da6ac7593afc3da9fb6d161ee413f60e76e670f0c84876591f331925c980d969db4e8c | ||
DIST mysql-connector-odbc-8.0.23-src.tar.gz 3726277 BLAKE2B 21b5e6f3f7e77d6107268800441675a230c79071e52db39093fade6e02031c12c96371d165af9459e9739e069e5b4196f0169dff54c0fa300e7a3023e8a82722 SHA512 2f66b5e1796176d638b1209b7d3381c2600a11cc88fa0dfb1f29b16a6c59386926674d5581d4843036d061af09312d58620484730bd7cdad36c0a0dcd45d49a9 | ||
DIST mysql-connector-odbc-8.0.24-src.tar.gz 3736373 BLAKE2B 8d03566471343239dd49f09bc02a0852f73544e0a91532e75d7871fa2842880213df0241691ab5449597bfed9dae3a74d87d2ed43092aad6bd66bee511542863 SHA512 1e182fd017092a47e38c96006a55d2d21496b2e5b67c211f9ea5b3c3cae44035bc9d401fc90c4f4e8ef6a347dbbbf78870b5dbc3711613fc28cddea468efa6f3 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,122 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake-multilib | ||
|
||
MAJOR="$(ver_cut 1-2)" | ||
MY_PN="mysql-connector-odbc" | ||
MY_P="${MY_PN}-${PV/_p/r}-src" | ||
|
||
DESCRIPTION="ODBC driver for MySQL" | ||
HOMEPAGE="https://dev.mysql.com/downloads/connector/odbc/" | ||
SRC_URI="https://dev.mysql.com/get/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="${MAJOR}" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
# Broken when built dynamically against libmysqlclient.so | ||
RDEPEND=" | ||
dev-db/unixODBC[${MULTILIB_USEDEP}] | ||
>=dev-db/mysql-connector-c-8.0:0=[static-libs,${MULTILIB_USEDEP}] | ||
" | ||
DEPEND="${RDEPEND}" | ||
S=${WORKDIR}/${MY_P} | ||
|
||
# Careful! | ||
DRIVER_NAME="${PN}-${SLOT}" | ||
|
||
# Patch document path so it doesn't install files to /usr | ||
PATCHES=( | ||
"${FILESDIR}/${MAJOR}-cmake-doc-path.patch" | ||
"${FILESDIR}/${PN}-8.0.19-cxxlinkage.patch" | ||
) | ||
|
||
src_prepare() { | ||
# Remove Tests | ||
sed -i -e "s/ADD_SUBDIRECTORY(test)//" \ | ||
"${S}/CMakeLists.txt" | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
mycmakeargs+=( | ||
-DMYSQLCLIENT_STATIC_LINKING=1 | ||
-DMYSQL_CXX_LINKAGE=1 | ||
-DWITH_UNIXODBC=1 | ||
-DWITH_DOCUMENTATION_INSTALL_PATH=${EPREFIX}/usr/share/doc/${PF} | ||
-DLIB_SUBDIR="$(get_libdir)/${PN}-${MAJOR}" | ||
-DMYSQLCLIENT_NO_THREADS=ON | ||
-DDISABLE_GUI=ON | ||
# The NUMA and LIBWRAP options are not really used. | ||
# They are just copied from the server code | ||
-DWITH_NUMA=OFF | ||
-DWITH_LIBWRAP=OFF | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
multilib_src_install_all() { | ||
debug-print-function ${FUNCNAME} "$@" | ||
|
||
dodir /usr/share/${PN}-${SLOT} | ||
for i in odbc.ini odbcinst.ini; do | ||
einfo "Building $i" | ||
sed \ | ||
-e "s,__PN__,${DRIVER_NAME},g" \ | ||
-e "s,__PF__,${MAJOR},g" \ | ||
-e "s,lib/libmyodbc3.so,$(get_libdir)/${PN}-${MAJOR}/libmyodbc${SLOT:0:1}a.so,g" \ | ||
>"${D}"/usr/share/${PN}-${SLOT}/${i} \ | ||
<"${FILESDIR}"/${i}.m4 \ | ||
|| die "Failed to build $i" | ||
done | ||
|
||
rm -rf "${ED}/usr/$(get_libdir)/${PN}-${MAJOR}/private" \ | ||
|| die "failed to remove bundled libs" | ||
|
||
mv "${D}/usr/bin/myodbc-installer" \ | ||
"${D}/usr/bin/myodbc-installer-${MAJOR}" || die "failed to move slotted binary" | ||
} | ||
|
||
pkg_config() { | ||
|
||
[ "${ROOT}" != "/" ] && \ | ||
die 'Sorry, non-standard ROOT setting is not supported :-(' | ||
|
||
local msg='MySQL ODBC driver' | ||
local drivers=$(/usr/bin/odbcinst -q -d) | ||
|
||
if echo $drivers | grep -vq "^\[${DRIVER_NAME}\]$" ; then | ||
ebegin "Installing ${msg}" | ||
/usr/bin/odbcinst -i -d -f /usr/share/${PN}-${SLOT}/odbcinst.ini | ||
rc=$? | ||
eend $rc | ||
[ $rc -ne 0 ] && die | ||
else | ||
einfo "Skipping already installed ${msg}" | ||
fi | ||
|
||
local sources=$(/usr/bin/odbcinst -q -s) | ||
msg='sample MySQL ODBC DSN' | ||
if echo $sources | grep -vq "^\[${DRIVER_NAME}-test\]$"; then | ||
ebegin "Installing ${msg}" | ||
/usr/bin/odbcinst -i -s -l -f /usr/share/${PN}-${SLOT}/odbc.ini | ||
rc=$? | ||
eend $rc | ||
[ $rc -ne 0 ] && die | ||
else | ||
einfo "Skipping already installed ${msg}" | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
elog "If this is a new install, please run the following command" | ||
elog "to configure the MySQL ODBC drivers and sources:" | ||
elog "emerge --config =${CATEGORY}/${PF}" | ||
elog "Please note that the driver name used to form the DSN now includes the SLOT." | ||
elog "The myodbc-install utility is installed as myodbc-install-${MAJOR}" | ||
} |