Skip to content

Commit

Permalink
dev-tcltk/tclpython: PythonCompatUpdate
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Feb 6, 2022
1 parent a80bb8c commit 6895431
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 2 deletions.
20 changes: 20 additions & 0 deletions dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
Original file line number Diff line number Diff line change
Expand Up @@ -24,3 +24,23 @@

ifneq ($(MAKECMDGOALS), clean)
-include $(DEPEND)
--- a/src/py.c 2022-02-06 10:20:03.352580186 +0100
+++ b/src/py.c 2022-02-06 11:16:49.504796684 +0100
@@ -24,7 +24,6 @@
// First time initializing Python
Py_NoSiteFlag = 1;
Py_Initialize();
- PyEval_InitThreads();
GlobalThread = PyEval_SaveThread();
}

@@ -60,7 +59,8 @@
#ifdef WITH_THREAD
PyEval_RestoreThread(interp->thread_state);
Py_EndInterpreter(interp->thread_state);
- PyEval_ReleaseLock();
+ PyThreadState_Swap(GlobalThread);
+ PyEval_SaveThread();
#endif

free(interp);
4 changes: 2 additions & 2 deletions dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8,9} )
PYTHON_COMPAT=( python3_{8..10} )

inherit python-single-r1 toolchain-funcs

Expand Down

0 comments on commit 6895431

Please sign in to comment.